6

I'm trying to set up my Google calendars on Evolution. When I add my gmail account it correctly imports the main calendar. However, when I try to add additional calendars I run into problems.

If I do New --> Calendar --> Google, enter my username and password, and then try to retrieve the list of calendars I get this raw html shown:

Authentication required: <HTML>
<HEAD>
<TITLE>Fobidden</TITLE>
</HEAD>
<BODY BGCOLOR="#FFFFFF" TEXT="#000000">
<H1>Forbidden</H1>
<H2>Error 403</H2>
</BODY>
</HTML>

If I try to add it via New --> Calendar --> On the web, and use the XML link I get a message:

Error loading calendar 'Unnamed'
Unable to connect to 'Unnamed': Cannot open calendar: Forbidden

Does anyone have any ideas how to fix this?

  • First remove or disable UOA integration. And use caldav method instead of Google(Or right click on primary calendar & select properties). In the url field it should be something like: https://www.google.com/calendar/dav/YOURUSERNAME@gmail.com/events. Use your full user name for both username & email. Then click on find calendars. Enter your password. Does this help? – Khurshid Alam Dec 3 '14 at 14:08
  • @Khurshid-Alam it almost works. I can access the calendar and add new invites (so thank you!). However, if I try to edit existing events I get "Authentication Failed". That's not a showstopper for me though. – elParaguayo Dec 3 '14 at 15:21
  • Yes. That's probably a bug. Try restarting evolution-data-server( a reboot will do).A better way to sync google calendar is to use syncevolution. Find instruction here: help.ubuntu.com/community/SyncEvolution/… – Khurshid Alam Dec 3 '14 at 16:52
  • Reboot didn't fix it. I may take a look at syncevolution - I'd seen it when searching earlier but I was hoping for Evolution to work on its on. Do you want to post your comments as an answer so I can accept it? – elParaguayo Dec 3 '14 at 18:03
6

This is what you should do:

  • First remove or disable UOA integration.
  • And use caldav method instead of Google(Or right click on primary calendar & select properties).
  • In the url field it should be something like:

    https://www.google.com/calendar/dav/YOURUSERNAME@gmail.com/events.

  • Use your full user name for both username & email. Then click on find calendars. Enter your password.

  • Select the desired calendar & click apply. It will appear in evolution.
  • Repeat above steps for other calendars.

DONE!


Another way to sync google calendar with caldav & UOA is to use syncevolution.

  • Also works on Debian Jessie (Evolution 3.12). No need to disable anything though; just add CalDav calendars instead of Google calendars in addition to the default Google calendar. – René Jan 24 '16 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.