1

Okay, so I was trying to get my flash player to work on Amazon prime video's DRM protected content. I Google's some things and it said I should install a thing called hal.

I tried it using apt-get and it failed, so tried apt-get update, got 404 error on some repos. Then tried to do a dist-update and that failed with some error.

Then I googled the error and one post told me to try something like sudo dpkg -P gnome-applet and of course I (stupidly) did it. Then my fire fox stopped working properly. I could do one google search and it then froze. I couldn't even look at my browsing history pre-freeze.

Then I tried rebooting and now I don't get anything on screen post partition select. But when I press my power button I get there normal shutdown animation.

Also I think I'm on Ubuntu 14. Something.

Any ideas?

Cheers!

0

Firefox should work fine without any flash player, just won't have some flash videos & ads & stuff. This sounds more like the flash player was crashing constantly.

And your repos or your net connection to them could have been temporarily down, (or they could have been old repos or mirrors that were removed) trying to fix those errors would have been the best thing to do.

dpkg -P means "remove these packages" (always see man [command] or info [command] before blindly running terminal commands). There is a gnome-applets I'm not running Unity or gnome (on xfce) but if I were to install gnome-applets it would also install these:

gir1.2-panelapplet-4.0 (3.8.0-1ubuntu12.2)
gnome-applets (3.5.92-0ubuntu3)
gnome-applets-data (3.5.92-0ubuntu3)
gnome-panel (3.8.0-1ubuntu12.2)
gnome-panel-data (3.8.0-1ubuntu12.2)

I don't know exactly what you removed, but if you removed gnome-panel it may not let you load a desktop, it sounds pretty important. I'd guess you want to re-install gnome-panel and gnome-applets.

If you can still boot to a terminal (try ctrl+alt+F1 (or with F2 through F6) to get to another terminal/console and install those (with apt-get install gnome-panel gnome-applets ). And after booting, ctrl+alt+F7 may show some info on how far the desktop did load, and ctrl+alt+F8 should get back to the desktop.

Also lsb_release -a should tell you what you're running.

  • Thanks! I managed to get to a terminal with ctrl-alt-f1, installed gnome-panel/applets, but still no luck! – Greg Cawthorne Dec 3 '14 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.