0

It seems everyone else has got the exact opposite of my problem. They can't boot from Live CD but not other way around as I am...or at least that's what I'm assuming the problem is.

Here's what I did. I have an acer iconia tab w500 tablet (windows 7) with dvd-rom, 1TB usb3-hard drive and other stuff connected to it via USB, like a finger scanner) and I decided to try Ubuntu on a tablet.

Burn the ISO to a DVD, booted from DVD, partitioned it to ext4 with swap and installed but soon as it restarts its just keep booting from the Live CD and not from where it s installed (the 1tb hard drive).

If I take the cd out, it just gives error like "can't found live cd source". By the way there is already Windows 7 installed on tablets internal storage(32GB)

I installed Ubuntu on the external hard drive, so on the boot screen it asks which OS I want.

Before the installation the, tablet didn't boot from the Live CD and straight opened windows 7. I can't change BIOS settings and see which device is booting first (since I've got no external keyboard to press F2 after pressing correct buttons on the tablet).

I had to choose this option from the Ubuntu Live CD menu in Windows to install this additional autorun setting.

6
  • is there another way to remove this without getting into bios..I'm not keen to walk to town just to buy a keyboard :D .if i could only now what did it changed I can undo it from windows. afterall it installed that from windows – bergdi Dec 2 '14 at 21:09
  • Did you install using WUBI.EXE within Windows 7. If so, you can Uninstall Ubuntu from inside Windows. I have no other ideas. Sorry. – user68186 Dec 2 '14 at 21:26
  • 1
    A tablet *should* have a way to get to the bios without needing anything external like a keyboard, that only makes sense, but it is probably made for or by windows/ms so all bets are off... lol – Xen2050 Dec 2 '14 at 22:47
  • 1
    It has...you press the power button and windows start button simultanously..and that opens another screen just before boot, asking you to press F2 to confirm whether you want to open BIOS. It's just stupid..you can do almost everything without a keyboard in BIOS with this tablet just by using volume-up, volume-down (to navigate) and start button (to confirm)(and few more things with other two onboard buttons) but noway you can't get in to BIOS without that bloody f2-key. – bergdi Dec 2 '14 at 23:09
  • 1
    I saw this article on techradar.com where they tried this linux on tablets venture and I just happened to have exact same model they've used and they seem to be pretty happy about the results(espacially with ubuntu...they tried few other distros aswell). thats why I wnted to try :D – bergdi Dec 2 '14 at 23:11
-1

If anyone thinks these images are OTT, please comment and I'll shrink them. I'm trying to be funny, I'm probably not managing

This is because the bios is in the wrong order. You need to set the external HDD as the first boot item.

Solution? Buy one of these?

enter image description hereenter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

Is there another way to remove this without getting into BIOS? I'm not keen to walk to town just to buy a keyboard. If I could only now what did it changed I can undo it from windows.

Nope. You need to buy one of those.

BIOS is the problem, BIOS is the fix.

3
  • (a) I don't think he understood the difference between a WUBI and full install. (b) He still needs a keyboard to get to BIOS to change the boot order to do a full install, after undoing the WUBI stuff. – user68186 Dec 3 '14 at 20:06
  • I tried downvoting your answer. It still shows up on top, as it is the accepted answer. – user68186 Dec 3 '14 at 20:52
  • Okay, well leave it down voted, the order may change :) – Tim Dec 3 '14 at 20:53
1

From reading all the comments I understand you tried to install Ubuntu using WUBI.EXE from within Windows.

See Is WUBI installation a full installation, or is it a live CD with persistent file or partition? and How do I know if I am running Wubi or a proper dual-boot? for more on WUBI.

WUBI does not use the GRUB bootloader, but uses Windows' own bootloader. It looks like the Windows bootloader somehow got misconfigured to point to the LiveDVD instead of the correct boot initiation file probably something like c:\ubuntu\winboot\wubildr.mbr.

Without Buying a Keyboard:

You can try to fix the Windows boot loader and make it point to the right file. See this HowToGeek for details.

With a keyboard:

Or you can delete the WUBI install by booting Windows and using Control Panel > Programs > Unisntall a Program > Ubuntu. Then you will need to go into BIOS (using the keyboard you need to buy) and set the tablet to boot from the Live DVD and do a complete install (not WUBI).

If you installed Ubuntu in an external USB drive:

Remember to put the bootloader (GRUB) in the same external USB drive. It may be /dev/sdb, /dev/sdc or some such thing. Don't put it in any specific partition such as /dev/sdb1 or /dev/sdc1 etc.

Once Ubuntu is installed, you may have to change the boot order in the BIOS again. Set it to the drive where Ubuntu is installed. If the external drive is attached it should show GRUB and give you the choice to boot Ubuntu (default) or Windows. If the drive is not present during boot, the tablet should boot straight to Windows.

-1

Have you tried using Boot-Repair-Disk from sourceforge.com. I have had the same issue using an external hard drive. When you boot-up the Boot-Repair-Disk, one of the questions it will ask is if one of your hard drives is external, answer YES and allow the disk to setup GRUB with your external drive. The Boot-Repair-disk download is free, just burn it to DVD, its a very good tool to have on hand. Hope this helps!! When you asked your question, you said you installed ubuntu on your 1TB internal hard drive that had windows on it, and at the end of your question you said you installed it on an external drive? If you installed it onto the external drive GRUB needs to know this to set up properly.

5
  • Pretty sure this isn't needed... – Tim Dec 2 '14 at 21:12
  • Tim, user68186 and jim frederick thanks for your advice. jim frederick: unfortunately its not booting from cd or usb stick..tried both of them(boot-repair-disk) few mins ago..its weird though,cd-dvd-rom clearly isn't the primary boot device and thats why it couldn't boot from the live-cd at first, only after I selected that option from WUBI.exe in Windows it somehow forced my tablet to boot from live-cd, or atleast it wrote an autoconfig-alike stuff to somewhere in internal harddrive(where windows is installed).If this so why can't I remove this without entering BIOS or more ...... – bergdi Dec 2 '14 at 22:57
  • importantly if such a autoconfig exist and enables computer to boot from cd without getting in to bios settings why can't I just configure this code(or whatever) to make it boot from external harddrive. another thing is there is only 2 option at the boot menu: one is Windows other is Ubuntu, but if I choose Ubuntu it just says something like "completing ubuntu installation" on a blackscreen and countsdown from 3 and then boots from live-cd....... – bergdi Dec 2 '14 at 22:58
  • ...and as for you Tim: I'm afraid you're dead right :D I have to get to the nearest store and get one of those. It's frustrating because I was there just today to buy this 1TB external harddrive just for this "ubuntu on a tablet" venture and I was this close buying a keyboard aswell because I suspected something like this would happen....why is this comment section heavily restricted to ~200 words – bergdi Dec 2 '14 at 22:59
  • @berkdi Hey. A few tips: When you want to notify someone, you put an @ in front of their name, like I did for you. Then they get an alert saying they have a message. You can only notify 1 person. Also, I won't get notifications when you comment here because this isn't my answer - you have to comment on mine to notify me. Finally, if you click the tick below my answer it shows that that is the accepted answer - I get some points for it too which makes me happy. The comments are restricted because that's what they are - comments. It's 599 characters (~125 words). The help center may help you here. – Tim Dec 3 '14 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.