7

just installed Skype 4.3 on my laptop (Dell Inspiron N5110) running Ubuntu 14.10 following all the instructions from every possible source but when I try to launch it absolutely nothing happens.

What can I do to get it working? Here's what I get:

andi@Andi:~$ skype
skype: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
  • 1
    What output do you get if you open a terminal window and run the command skype? Please answer by editing your question and adding that piece of info. – Gunnar Hjalmarsson Dec 2 '14 at 19:15
  • Here's what I get " andi@Andi:~$ skype skype: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory " – Matei Alexandru Dec 2 '14 at 20:42
  • I suggest that you check out this solution: ubuntuforums.org/showthread.php?t=2233005 – user564480 Jul 4 '16 at 10:31
10

Open a terminal window and try to start Skype with this command (copy and paste):

LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 skype

If that's successful, I suggest that you check out this answer to get a persistent solution.

  • Thank you! I did as you said and it worked! My Skype is running gr8 now! – Matei Alexandru Dec 2 '14 at 21:04
  • @MateiAlexandru: Great! Then can you please "accept" my answer, so others see that the problem was resolved. – Gunnar Hjalmarsson Dec 2 '14 at 21:13
  • sorry to bother you yet again, but what do you mean by "accepting" your answer? I'm kinda' new around here, I switched to linux a few days ago and I ain't very familiar with the procedures :) – Matei Alexandru Dec 2 '14 at 21:35
  • I've sorted it out! Thank you once again for your help – Matei Alexandru Dec 2 '14 at 21:41
3

This solution worked for me on Ubuntu 16.04

sudo ln -st /usr/lib/i386-linux-gnu mesa/libGL.so.1

Make sure you have libgl1-mesa-glx installed.

  • +1 for mentioning that libgl1-mesa-glx needs to be installed. After installing it, everything worked for me even without making symlinks or setting LD_PRELOAD (though in my case it was Firefox inside a Docker container that didn't work). – skozin Oct 2 '16 at 15:30
0

For Ubuntu like systems, I confirm that the solution of Gunnar Hjalmarsson works:

LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 skype

(tested un xUbuntu 16.04) However, it doesn't work for debian.

The solutions for debian are listed here, and the solution for the libGl error is to run

sudo ln -s /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 /usr/lib/i386-linux-gnu/

Then everything works perfectly ! (tested on debian unstable with the debian binary from the official website on november 2016)

-1

If others like me ends up here trying to solve this problem, the solution could be to reinstall bumblebee with the following:

sudo apt-get install bumblebee-nvidia --reinstall

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.