I have a dual boot with Windows 7. The wired connection works on Windows 7 both on my work network (static IP assigned) and on my home network (DHCP). Neither works on Ubuntu. Below is from work. Help?

eth0      Link encap:Ethernet  HWaddr ec:f4:bb:5a:60:13  
      inet addr:  Bcast:  Mask:
      inet6 addr: fe80::eef4:bbff:fe5a:6013/64 Scope:Link
      RX packets:1169 errors:0 dropped:0 overruns:0 frame:0
      TX packets:510 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:93339 (93.3 KB)  TX bytes:63135 (63.1 KB)
      Interrupt:20 Memory:f7800000-f7820000 

lo        Link encap:Local Loopback  
      inet addr:  Mask:
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:875 errors:0 dropped:0 overruns:0 frame:0
      TX packets:875 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:70441 (70.4 KB)  TX bytes:70441 (70.4 KB)

wlan0     Link encap:Ethernet  HWaddr f8:16:54:ce:b8:d2  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

sudo lshw -C network
   description: Ethernet interface
   product: Ethernet Connection I217-LM
   vendor: Intel Corporation
   physical id: 19
   bus info: pci@0000:00:19.0
   logical name: eth0
   version: 04
   serial: ec:f4:bb:5a:60:13
   size: 1Gbit/s
   capacity: 1Gbit/s
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k duplex=full firmware=0.13-3 ip= latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
   resources: irq:45 memory:f7800000-f781ffff memory:f783d000-f783dfff ioport:f080(size=32)
   description: Wireless interface
   product: Wireless 7260
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlan0
   version: 73
   serial: f8:16:54:ce:b8:d2
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-39-generic firmware= latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
   resources: irq:47 memory:f7700000-f7701fff

Try this.

If this is a desktop installation using Network Manager, then no declaration of eth0 is needed in /etc/network/interfaces. Network Manager should do the job perfectly well. Moreover, the file is slightly malformed. I suggest you edit the file as follows:

auto lo
iface lo inet loopback

Proofread, save and close the text editor. Reboot and let us have your report.

Sometimes, the troublesome r8169 will connect if you specify some capabilities, instead of letting the card and router negotiate. Please do:

gksudo gedit /etc/rc.local

Use nano or kate or leafpad if you don't have the text editor gedit. Add one line right above exit 0:

ethtool -s eth0 autoneg off speed 100

Proofread carefully, save and close the text editor. Reboot and, if it doesn't connect, let us see another paste as below.

  • Problem solved, thank you! (At work, at least; will double check at home later.) The /etc/network/interfaces file already looked like what you suggested, but after I edited the rc.local file and reconnected to my work wired option, it worked. No reboot was required. – Heather Dec 2 '14 at 15:05
  • Never mind. After rebooting it stopped working. I tried re-editing the files you mentioned every which way, to no effect. The resulting ifconfig and lshw only changed in the following ways: 1) TX/RX bytes and packets different for eth0 and lo, and 2) *-network for Ethernet interface changed to configuration: autonegotiation=off – Heather Dec 2 '14 at 21:52

Success! The issue was the e1000e driver.

Solution here: http://www.intel.com/support/network/sb/CS-032514.htm

And this answer has instructions on how to make the solution persistent across reboots: How do I install Intel ethernet drivers?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.