0

Problems started after an unexpected power loss while executing apt-get dist-upgrade.

When I now run command (as root) apt-get dist-upgrade and got the following output:

Reading package lists ... Done
Building dependency tree.
Status information is read .... Done
Try 'apt-get -f install' to correct this.
The following packages have unmet dependencies:
libc6: Depends: but is not installed libgcc1
E: Unmet dependencies. Try to use -f.       

Then I run apt-get -f install and get:

 Reading package lists ... Done
 Building dependency tree.
 Status information is read .... Done
 Correcting dependencies ... Done
 The following extra packages will be installed:
   libgcc1
 The following NEW packages will be installed:
   libgcc1
 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
 2 not fully installed or removed.
 Need to get 0 B of archives still 47.9 kB.
 After this operation, 156 kB disk space will be used.
 Would you like to continue? [Y / n] y
 E: Can not get debconf version. Is debconf installed?
 debconf: apt-extracttemplates failed: File or directory not found
 dpkg: pre-dependency problem concerning ... / libgcc1_1% 3a4.9.1-0ubuntu1_i386.deb which libgcc1: i386 contains:
  libgcc1 depends (in advance) of multiarch-support from
   multiarch-support is unpacked, but has never been configured.

 dpkg: error processing the archive /var/cache/apt/archives/libgcc1_1%3a4.9.1-0ubuntu1_i386.deb (--unpack):
  Pre-dependency problem - libgcc1: i386 is not installed
 Errors were encountered while processing:
  /var/cache/apt/archives/libgcc1_1%3a4.9.1-0ubuntu1_i386.deb
 E: Sub-process / usr / bin / dpkg returned an error code (1)

When I run dpkg-reconfigure -f libgcc1 i get (also other dpkg-reconfigures will not help):

debconf : unable to initialize surface : libgcc1
debconf : ( Can not locate Debconf/FrontEnd/Libgcc1.pm in INC ( You may need to install the Debconf :: Frontend :: libgcc1 module) ( INC contains: /etc/perl/usr/local/ lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl.) at (eval 34)line 2.)
debconf : fall back to the surface : nonInteractive 
/usr/sbin/dpkg -reconfigure : please choose a package that you want to reconfigure

What should I try now to solve this problem of this package which is extracted but not configured? In the current state there is a circular dependency libgcc1 and multiarch-support.

I would be very glad if you can help me, nothing I know to fix problems with packages helps.

  • While im not entirely fluent in Duecth, not many others are. Could you translate the log file? – Virusboy Dec 1 '14 at 20:41
  • @Theoboldt: You set the language of the messages of any (well-behaved) program to English by setting the environment variable LC_MESSAGES to the value C, e. g. LC_MESSAGES=C apt-get .... – David Foerster Dec 1 '14 at 22:10
  • Thanks Virusboy for updating the content with english translations... THe problem is; libgcc1 can not be installed because multiarch-support is not ready configured, but multiarch-support needs a functional libgcc1. – Erik Theoboldt Dec 1 '14 at 22:58
0

It was impossible to solve this circular dependency. I had to reinstall the operating system to solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.