2

I'm running ubuntu 14.04 LTS on my computer with 7.8GiB Memory, Intel Core i5 CPU 760 @ 2.0GHz x 4 Processor, Gallium 0.4 on AMD REDWOOD Graphics, OS 64bits and 40GB of Disk.

Recently my network stop working and after digging a lot on google and here on this forum Im giving up on my research and making my problem public in here.

When I click on my network manager on the right of the top bar it wont show either the wired connection and wireless connections as it used to before.

The options that are current showed are:

  • Ethernet Network (not active)
  • device not managed (not active)
  • VPN Connections
  • Enable Networking (selected)
  • Connection Information
  • Edit Connections...

I tried a few things with my /etc/network/interfaces but nothing worked so far. I've tried to manually add a network but without success so far and when I click on Connection Information I get a popup with an error saying "Error displaying connection information: - No valid active connections found!"

My /etc/network/interfaces file content:

# interfaces(5) file used by ifup(8) and ifdown(8)

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

I don't know what else I can do and I'm open to ideas.

  • Is there anything in your interfaces network configuration? Somewhere like /etc/network/interfaces, could you post that file? – Robobenklein Dec 1 '14 at 19:34
  • Yeah. My interface files currently have the following. I was thinking if maybe I need to change it's permissions. #interfaces(5) file used by ifup(8) and ifdown(8) auto lo iface lo inet loopback auto eth0 iface eth0 inet dhcp – Vinicius Santana Dec 1 '14 at 19:54
  • please note that I added the last 2 lines trying to resolve the issue. They weren't there originally when the problem started. – Vinicius Santana Dec 1 '14 at 19:59
  • Yeah you should remove those lines to enable the management by NetworkManager. Those lines are preventing the device from being auto managed. – Robobenklein Dec 1 '14 at 20:03
  • Oh wow. It worked. It's one of those things. I tried this before without success and now it worked just fine. Thanks though. I appreciate your time and help. – Vinicius Santana Dec 1 '14 at 20:07
2

The solution is to remove the non-default lines in the network device configuration in /etc/network.

For example, if

auto eth0
iface eth0 inet dhcp

Appears in your /etc/network/interfaces then NetworkManager won't be able to manage the eth0 interface.

  • it would be great,if you can say what are the default and non defaults..really helps novice users – TheGameiswar Jul 31 '17 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.