0

I tried to launch the Unity Tweak tool, which had been working fine before, and it wouldn't work at all. When I do it from the terminal, I get this:

user@chrubuntu:~$ unity-tweak-tool
Traceback (most recent call last):
  File "/usr/bin/unity-tweak-tool", line 72, in <module>
    UnityTweakTool.Application()
  File "/usr/lib/python3/dist-packages/UnityTweakTool/__init__.py", line 79, in __init__
    executable_name=cmd_old.split('\x00')[1]
IndexError: list index out of range

How do I fix this?

1

Navigate to init.py file and edit the file

Comment file from line 79 to 89

It worked for me!

4
  • I am not very experianced so you might have to spell a few things out from me. LIke where is the file and what do you mean by Comment from line 79 to 89 – SnorriChinchilla Dec 3 '14 at 2:38
  • 1
    nano /usr/lib/python3/dist-packages/UnityTweakTool/__init__.py Go to line 79 and comment till 89. – LostLife Dec 4 '14 at 10:26
  • What do you mean by comment, I can open the file. – SnorriChinchilla Dec 5 '14 at 18:44
  • Okay, I figured it out, but it didn't work. – SnorriChinchilla Dec 22 '14 at 19:34
1

It says: "list index out of range". So, you could change 1 to 2:
1. executable_name=cmd_old.split('\x00')[1] //Change it
2. executable_name=cmd_old.split('\x00')[0] //to this


In order, to do that open terminal and type:

sudo gedit /usr/lib/python3/dist-packages/UnityTweakTool/__init__.py 

Then, go to line 79, executable_name=cmd_old.split('\x00')[1] will be there.

Good luck!

2
  • Where do you suggest to change it? – Pilot6 Jul 18 '15 at 20:13
  • I've updated my answer. Please, take a look at it. – rzaaeeff Jul 18 '15 at 20:45
0

You guys were right, but I didn't know what to do. I copied and pasted this instead https://launchpadlibrarian.net/163835720/init.py

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.