2

I am setting up a computer for our grad students at my university. I have one standard-user login for all of them to use to make things a bit simpler for them. I am trying to find a way, however, to have the WiFi connection ask for BOTH the username and password when trying to connect to the Univ's wireless system. We connect via WPA2, PEAP, MSCHAPv2, with NO cert required to connect. Getting the connection to ask for the password each time is easy enough, but there is no setting to do the same for the username. I'm running 14.04.

Any help/options would be greatly appreciated. I REALLY don't want to have to set up EACH of our grad students with usernames to access these computers.

@muru

Removing the identity= line altogether causes the connection settings to completely reset for some reason. I have to put in all of my settings from scratch. I also tried inserting the lines leap-identity-flags=1 under the 802.11 wireless security heading and identity-flags=2 identity-raw-flags=1 under the 802.1x heading. This mirrored the password settings, so I hoped it would do the same for the username, but it results in completely causing the connection settings to reset upon reconnect.

Update - Figured out why the connections reset. When I make changes through nano, once saved the connection does not show up under the "Edit Connections" option, and connecting to the WiFi again causes a new profile to be made.

I can see the original connection via terminal, along with the new WiFi connection, just not through the GUI. The new connection when looked at in a terminal window is named differently than the original, as you can see below; The first ls is before the edit, the second ls after the nano edit:

root@jayadmin-OptiPlex-GX280:/etc/NetworkManager/system-connections# ls
MU WiFi  Wired connection 1
root@jayadmin-OptiPlex-GX280:/etc/NetworkManager/system-connections# ls
MU WiFi  MU WiFi-d9a0a44b-0d73-4dac-92a6-1158d2d1fdf9  Wired connection 1
root@jayadmin-OptiPlex-GX280:/etc/NetworkManager/system-connections#

Update #2

SO, apparently this was a change made when 12.04 was released; before 12.04, users had the ability to leave the user and pass both blank to fill in each time, but for some reason the devs took away this ability in 12.04.

Surely, though, there is a way to manually get around this through terminal. Suggestions still greatly appreciated...I'm stumped atm...

  • Try editing /etc/NetworkManager/system-connections/<connection-name> and removing the identity=... line. – muru Dec 1 '14 at 16:41
2

This is a change made from v12.04 and not an actual "bug," and should probably go to the "developer suggestion box" than in a support forum. Thanks anyway, people.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.