0

This morning I ran sudo apt-get upgrade and it prompted me to update gnome-shell. I never really use the gnome desktop environment, but I figured I might as well keep it up-to-date.

After restarting my laptop I noticed that lightdm had selected gnome as the desktop environment and when I tried to switch it back to unity I noticed that unity was missing from the list.

Unity is still installed somewhere, but it seems to have been removed from /usr/share/xsessions/. I've tried running sudo apt-get install --reinstall unity, but it doesn't seem to have changed anything.

I've checked this answer here and it suggests that the solution is to remove gnome-shell. I'm a bit hesitant to do this though, if I remove gnome-shell and unity doesn't come back I'll be left without any desktop environment.

1

You just need to turn the Unity plugin back on. The problem is this is a pain in the bottom because you've now got no graphical method to do this. So:

Install the jibby you'll need to configure the settings by running this:

sudo apt-get install compizconfig-settings-manager

2.Then run it by doing this:

export DISPLAY=:0
ccsm

There will be CompizConfig Settings Manager screen (or open it from menu).

Find the Unity plugin. Enable it.

Everything should spring into life but if it doesn't, you might have to restart.

Source:Unity doesn't load, no Launcher, no Dash appears

  • Do I need to uninstall gnome-shell first? I tried following those instructions without uninstalling but unity still doesn't show in lightdm after restarting. If I load compizconfig-settings-manager it now says that the unity plugin is enabled though. – jessenorton Dec 1 '14 at 13:37
  • No, you dont need to uninstall gnome-sheell ..have you tried resinstalling gnome session...................................... sudo apt-get --reinstall install gnome-session. – vinrav Dec 1 '14 at 13:48
  • Of course reboot the machine after it.. – vinrav Dec 1 '14 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.