0

This might seem like a silly question but by golly I've tried and tried for a whole week and no results. I don't know if it's something wrong with my queries, or too much "Install Xampp" clutter in my search results (and not Upgrade Xampp) - But I just can't find a solution that works on my server.

I've got Ubuntu Server 12.04 (Terminal only), and on it phpstatus = 5.4.7 (i.e. Xampp version is 5.4.7).

I want to upgrade said Xampp (Lampp...) to the latest, which according to the file downloaded from apachefriends com - is 5.6.3

I've tried the following two sets of instructions (which strangely enough are the ONLY ones I managed to find online) to no avail. After using either apt-get or the bitnami GUI (via SSH with PuTTy + Xming) - the command phpstatus still outputs 5.4.7

I've even tried both methods under the actual root user on the device. No success there either.

After reading the apachefriends FAQ I thought that in order to upgrade, all I need to do is install Xampp in it's newest version right over the old Xampp installation. But maybe it's not the case?

Please - I need some help here. How do I upgrade my Xampp and why isn't it working with the methods I've tried?

Here are the two methods I've tried. Copied directly as I found them online:

Ensure the XAAMP repository is added:

sudo add-apt-repository ppa:upubuntu-com/xampp

Then update with:

sudo apt-get update

That was one method, here's the other:

How do I install XAMPP?

Choose your flavor for your linux OS, the 32-bit or 64-bit version.

Change the permissions to the installer

chmod 755 xampp-linux-*-installer.run

Run the installer

sudo ./xampp-linux-*-installer.run

That's all. XAMPP is now installed below the /opt/lampp directory.

What could I be missing?

4

Uninstall lampp with the following command:

sudo /opt/lampp/uninstall

This will keep untouched three folders in your installation directory (htdocs, temp and var). Htdocs is the folder which contains the files and var is the folder which contains the databases of all your projects.

Afterwards, change the permissions of the installer you downloaded

chmod 755 xampp-linux-*-installer.run

and run the installer

sudo ./xampp-linux-*-installer.run

All done. XAMPP is now installed under /opt/lampp directory.

1
  • why "pkexec ./xampp-manager" doesn't work? Why we need to use "sudo" for GUI app?
    – Pranav
    Jan 19 '20 at 8:37
0

Regarding the PPA. If you look at their launchpad page you will see that it is 110 weeks old. By the way: their PPA states it is version 1.8.1. That seems WAY off from your version. Looking at the XAMPP download page that seems to be explained by a skip in version numbering. So do not bother with the PPA; it seems dead.

Looks like their numbering got changed to the PHP version related to the XAMPP version. So you will also want to update PHP to 5.6.3. This might become problematic and you might need to switch to Ubuntu 14.04

Regarding installation from the run file. The "*" in that denotes the version so if you downloaded. 1 thing you need to consider: the version you type is the 32-bit version. If you need the 64-bit version you need xampp-linux-x64-5.6.3-0-installer.run.

You will also need to do the post install alterations. Change your PATH variable to the new download and execute the daemon. Like you did the 1st time.

2
  • As for the PPA - Got it. Thank you :) As for the rest... The asterix (*) was indeed changed (I just inputted the filename where applicable. What do you mean I'll have to update PHP as well? Isn't the whole point of Xampp that it's a bundle? And doesn't that bundle include Apache, MySQL and PHP? So why would I need to update them separately after updating the whole package? The point was to update all three at once. This part of your reply got me somewhat confused. Also... Will I have to update to 14.04? Are you sure? This might be a killer annoyance :( (From Ubuntu 12.04.3 LTS) Thank you. Dec 1 '14 at 14:42
  • After going through my installation documentation (which I wrote/rewrote while installing the whole server setup), I found the command 'sudo /opt/lampp/lampp status'... according to it's output, I indeed seem to be running Xampp for linux 1.8.1 This is so very confusing. I don't understand how versioning works on xampp... And which xampp version is in here then? It only shows the PHP version number as far as I can tell... Dec 1 '14 at 15:21
0

if you are using xampp older version and need to upgrade it to newer one you donot need to worry in ubuntu just download the newer version and run the commad: ./xampp.run

it will automatically upgrade the last installed xampp in location /opt/lampp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.