13

I install just the OpenSSH server on hardware that was running 14.04 Server. Besides the pages of checks the startup goes through, I believe it should recognize scroll lock from an usb keyboard, but it does not.

Everything seems to be fine until I login and get:

[305.760849] system-logind[1419]: Failed to start unit user@1000.service: 
 Unknown unit: user@1000.service
[305.761004] system-logind[1419]: Failed to start user services: 
  Unknown unit: user@1000.service

Are the Two errors related to the OpenSSH since it has not been setup or are they related to something else?

I tried a search through the manuals and help files on the system and at Ubuntu without any success.

9
  • Ehm. This message is related to "systemd" and user sessions. It might be related to the openssh installation but... 1st a question... are you using systemd? ( freedesktop.org/software/systemd/man/logind.conf.html ) – Rinzwind Dec 1 '14 at 10:15
  • I would say no under 14.04 but in this case, I have not a clue. The login screen since I am connected directly to my server looks something like this: Ubuntu 14.10 Ubuntu tty1 – Thomas Shultz Dec 3 '14 at 0:04
  • It looks like I am using "systemd PID 1 ", I checked, if I wanted these errors to go away, I might have to edit some files. But why was this not taken care of upon installation? – Thomas Shultz Dec 3 '14 at 0:37
  • Under System, --user (manual), What I have read Ubuntu 14.10 thinks it is in test mode, that would explain the pages of information flying by my eyes during before the OS boot process. – Thomas Shultz Dec 3 '14 at 0:54
  • I just installed Ubuntu Server 14.10 on a laptop of mine. I get the same error message on the screen when booting. I don't get it through SSH. Tried reinstalling OpenSSH but no difference. – Mikael Dúi Bolinder Feb 1 '15 at 11:16
6

In order to redeem my reputation, I did some more research and tried a few things with my server. After doing the following I no longer get the error message and my server seems to be behaving normally. I used this page SystemdForUpstartUsers for guidance.

What it did I have not clue, but it seems to work. I have a feeling that Upstart and Systemd are conflicting. With forcing to install Systemd, Upstart is removed.

apt-get --force-yes install systemd-sysv ubuntu-standard
update-initramfs -u

here is my output:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  ubuntu-minimal upstart ureadahead
The following NEW packages will be installed:
  systemd-sysv ubuntu-standard
0 upgraded, 2 newly installed, 3 to remove and 0 not upgraded.
Need to get 8,548 B/11.4 kB of archives.
After this operation, 723 kB disk space will be freed.
Do you want to continue? [Y/n]
WARNING: The following packages cannot be authenticated!
  systemd-sysv ubuntu-standard
Install these packages without verification? [y/N] y
Get:1 http://us.archive.ubuntu.com/ubuntu/ utopic-updates/universe systemd-sysv amd64 208-8ubuntu8.2 [8,548 B]
Fetched 8,548 B in 4s (2,042 B/s)
(Reading database ... 132103 files and directories currently installed.)
Removing ubuntu-minimal (1.327) ...
Removing ureadahead (0.100.0-16) ...
dpkg: upstart: dependency problems, but removing anyway as you requested:
 friendly-recovery depends on upstart | systemd-sysv; however:
  Package upstart is to be removed.
  Package systemd-sysv is not installed.

Removing upstart (1.13.2-0ubuntu2) ...
Processing triggers for man-db (2.7.0.2-2) ...
Selecting previously unselected package systemd-sysv.
(Reading database ... 132056 files and directories currently installed.)
Preparing to unpack .../systemd-sysv_208-8ubuntu8.2_amd64.deb ...
Unpacking systemd-sysv (208-8ubuntu8.2) ...
Selecting previously unselected package ubuntu-standard.
Preparing to unpack .../ubuntu-standard_1.327_amd64.deb ...
Unpacking ubuntu-standard (1.327) ...
Processing triggers for man-db (2.7.0.2-2) ...

Hope this helps somebody.

2
  • I find this concerning: dpkg: upstart: dependency problems, but removing anyway as you requested: friendly-recovery depends on upstart | systemd-sysv; however: – Elder Geek Mar 26 '15 at 14:29
  • Just doing apt-get install systemd-sysv package solved the issue in a fresh installed 14.10. I found the answer in this thread: bugs.debian.org/cgi-bin/bugreport.cgi?bug=756247 – sw. Sep 13 '15 at 18:04
4

I also had this issue on a relatively fresh install of ubuntu 15.10 as above answer says this solved it for me

    sudo  apt-get install systemd-sysv

I had the same dmesg as above additionally my symptom included failure to boot up from a suspended state which forced me to cold boot each time

0

I tried this and it worked

do-release-upgrade -d 

You'll go to the development version with the "-d" switch.

With this specific server I started with 14.04, then did a "do-release-upgrade" which upgrade me to 14.10. This is when I started to have this same error message. So I found After update to Ubuntu 14.10... and decided to attempt this. I was then upgrade to version 15.

3
  • Would you be so kind as to explain exactly how this would resolve the OP's problem? My review of the question asked leaves me baffles as to why you would think this would be an answer. – Elder Geek Mar 24 '15 at 17:28
  • I had the same problem and doing this resolved my problem, of course this did upgrade my OS to the next Development version which I'm "ok" with. Granted it's not a fix but a band-aid. – GeekyDaddy Mar 26 '15 at 13:22
  • Please edit your answer and provide more information. What version you upgraded from is of course of interest. – Elder Geek Mar 26 '15 at 14:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.