0

When I install Ubuntu via VirtualBox, I can only have resolution of 640x480 or something similar. I found that I needed to install guest additions to get more resolution choices. Doing this makes my Ubuntu look like this in VM window:

enter image description here

I obviously can't navigate in this window and was wondering what my next course of action should be.

  • I remember that after installing Guest Auditions, I had the same problem. I reinstalled the Guest Auditions, again, and it work, but have no idea why. Please try reinstalling, maybe it's the same problem. – Melon Dec 1 '14 at 7:43
  • I have tried to reinstall, but I get a mounting error and nothing happens. How did you reinstall? I cannot do it thru terminal because I cannot see anything in the GUI ...I tried uninstalling and reinstalling the Ubuntu build and reinstalling additions but it does not fix the problem. – disengage Dec 1 '14 at 7:46
  • Does switching to other terminals work Ctrl - Alt - F4 ? – Melon Dec 1 '14 at 7:49
  • Did you select Auto Resize HOST + G and Adjust Window Size HOST + A in the Virtual Box View settings? – Takkat Dec 1 '14 at 8:13
1

Open Terminal: CTRL+ALT+T

Install these Guest Additions Packages:

sudo apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11

Make sure you put your sudo user password and packages are installed correctly. After that installation is Done. Restart your VM

If the problem still stays... Try:

Go to System settings -> Software and Updates -> Additional drivers
Use x86 virtualization solutions...
After that reboot your virtual box

Source: Screen Resolution Problem with Ubuntu 14.04 and VirtualBox

After doing this if you still have the same resolution:

Open Terminal CTRL+ALT+T (Hotkey) type in terminal:

xrandr -s 1024x768

It will set your screen resolution to 1024x768

  • I cannot do that because I cannot navigate the ui. Perhaps uninstall and do that before installing additions? – disengage Dec 1 '14 at 14:33
  • Tried the above answer, still does not work. Just the window is not as small now. i.imgur.com/QfA7vjy.jpg – disengage Dec 1 '14 at 15:47
  • Open Terminal CTRL+ALT+T (Hotkey) type in terminal: xrandr -s 1024x768 – LostLife Dec 1 '14 at 15:54
  • Can't access terminal because screen resolution auto resizes to smaller resolution. – disengage Dec 1 '14 at 15:56
  • just type: ctrl+alt+t (it will open terminal) then type the command i have written and press enter and tell me what it does..(you dont have to see anything) – LostLife Dec 1 '14 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.