0

I've looked at all of the forums, and tried doing multiple fresh installs and continue getting the error "Unable to install GRUB in /dev/mdx - This is a fatal error"

My current setup is 2 2T drives, using Software RAID1.

Here is my current partition table. At the end when the GRUB bootloader asks where to boot from i enter: /dev/md2 (which is a separate /boot partition I created after reading many forums).

I've looked into /dev/mapper (as per multiple forums have suggested) and the only contents are "control".

I've tried wiping the whole thing multiple times and starting over and the GRUB bootloader still won't boot, and it won't even let me install and boot without GRUB.

0

You need to select the actual disk drives ( /dev/sda, /dev/sdb, etc ) for where to install grub to.

  • I've tried that numerous times and get the same fatal error. – atavel Dec 1 '14 at 4:01
  • Check /var/log/syslog and find the exact error reported and edit it into your question. – psusi Dec 1 '14 at 4:08
  • wow. I've been trying /dev/sdb3 ect instead of just /sdb....got it. Thank you! – atavel Dec 1 '14 at 4:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.