I have been using Xubuntu (latest version 14) for quite a while, and I love it. However, recently I was using the Thunar File Manager, and decided to see what it looks like with a little more real estate by disabling the top Menu Bar in the Views function. Well, Thunar did what I asked it to, but now without a Menu Bar, I have no way of getting back to the View menu to re-activate the Menu Bar. I tried Alt-V and Alt-Shift-V, but nothing happens. HELP! How do I get my Menu Bar back? Thanks, Ray.


The shortcut for disabling and enabling the menu bar in my German version is Ctrl+M.

Try that.

  • Thanks for the info. Unfortunately, that doesn't seem to work. I tried Ctrl-M, Ctrl-Shift-M, Alt-M, and Alt-Shift-M to no avail. I thought that the standard short-cut key was Alt + (underlined_letter) on Menu Bar. So that would be Alt-V. For example, if I type Alt-V on Firefox, the View Menu drops down. But this feature doesn't seem to be implemented in Thunar. Oh, well .. back to the drawing board. BTW - This is interesting ... when I run Nautilus from Alt-F2 (Application Finder), the top Menu Bar is ALSO missing! And on Nautilus, I never touched any settings. Weird ... Anyway, thanks. Ray. Dec 1 '14 at 8:10
  • 3
    Worked for me, thanks @Minix! Sorry it didn't work for OP.
    – CompEcon
    Nov 20 '15 at 14:56
  • works in thunar 1.6.1
    – user47206
    Mar 10 '17 at 8:30
  • 1
    This works for the English version
    – MrMartin
    Oct 12 '17 at 9:16
  • 1
    Thanks for the tip! They should account for people pressing Ctrl+M by mistake and wondering where the menu suddenly disappeared! Jun 22 '18 at 11:34

Use F10 key to open or temporarily show the menu bar in Thunar.

The shortcut key behaves differently depending on menu bar visibility:

  • If menu bar in Thunar is visible, press F10 key once to open menu in menu bar.

  • If menu bar in Thunar is hidden, press F10 key twice to temporarily show and open menu in menu bar (same result as visible).

To make the menu bar always visible again:

  1. Press F10 key twice
  2. Use cursor keys to navigate to View > Menubar (Press right-cursor key twice, then press down-cursor key five times)
  3. Press Space key to select that menu
  4. Press Esc key to close the menu

The menu shortcut key is applicable to GTK+ applications including Thunar. Unlike the combination key Ctrl+M, the function key F10 will work as it is regardless of keyboard layout.

  • i couldn't get this to work for the terminal window — it interprets the f10 keystroke as a tilde input for the command line Jun 20 '18 at 3:23
  • i just discovered if i right-click the terminal contents, "show menubar" is listed as an option — this is not the case when i right-click the "window chrome" around the contents such as the icon and titlebar Jun 20 '18 at 3:25
  • I have at least clarified that Xfce Terminal in 18.04 works as expected even when menubar is hidden. Terminal window may not work properly in older releases. Otherwise, ask a new question instead.
    – user37165
    Jul 9 '18 at 7:42

xfce4-settings-editor is your friend.

  • Close all thunar windows
  • start xfce4-settings-editor from the console
  • locate thunar on the left hand tab
  • check last-menubar-visible
  • open a new thunar window



  • memorize the shortcut key for your locale :)
  • 1
    Thanks so much for your help. I did try the Settings Manager from the XFCE Menu a couple days ago (didn't need to start it from the console), but I didn't see any "left hand tab", or anything that said Thunar on it. So today I spent some more time fishing around for a solution, and I found a similar problem posted. The solution was to run from console: "xfconf-query --channel thunar --property /last-menubar-visible -s true". After I did that, when I loaded Thunar again, I had my menu bar back. I came to this page to inform everyone of the solution, but you beat me too it! Thanks again. Ray. Dec 2 '14 at 9:07
  • BTW ... The hot key to display the Menu Bar on Thunar in my locale (America) is Ctrl-M. But for some reason, when Aibara Iduas advised me to try that, it did NOT work. Nothing at all happened, and I tried Ctrl-M and Ctrl-Shift-M several times (when the property was set to false). But now it is working. Weird. Thanks again, Ray. Dec 2 '14 at 9:12


I find it trying every shortcut I could think. May that be helpful!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.