1

I have a problem with my graphics card. It's an NVIDIA GeForce 8600M GT, a bit old one.

After a fresh install of any Ubuntu release (it was 13.04 back then) everything works like a charm. After completing the huge portion of updates - everything went wrong with the GPU and screen resolution. My monitor / gpu combo are supposed to work at 1280x800, and the laptop itself was able to run the Witcher game (under WIndows OFC).

Now after those updates:

  • max screen resolution I can set is 1024x768, and the graphics seem to be 'stretched'.

Gnome/Unity seems to work slow as hell.

I Tried to force other resolution options by creating the xorg.conf file with the graphics section and screen section looking like this:

Section "Device"
   Identifier  "NVIDIA GeForce 8600M GT"
   Driver      "nvidia"
   VendorName  "NVIDIA"
   BoardName   "8600M GT"
   Option   "NoLogo"    "true"
   Option   "AllowGLXWithComposite" "true"
   Option   "Coolbits"  "1"
   Option   "Triplebuffer"  "true"
   Option "OnDemandVBlankInterrupts" "true"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "NVIDIA GeForce 8600M GT"
   Monitor    "Dell Inspiron 1520 WXGA+ LCD"
   DefaultColorDepth 24
   SubSection "Display"
           Depth     24
           Modes "1440x900" "1280x800" "1280x768" "1280x720" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
           Depth     32
           Modes "1440x900" "1280x800" "1280x768" "1280x720" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

But this aint helping at all.

I've tried the proprietary drivers from NVIDIA, nothing worked. The open source drivers (nouveau) aint working either...

I just don't know what to do.

1

In my case, adding this line to "Device" Section of the xorg.conf file solved the problem.

Option      "ModeValidation" "NoMaxPClkCheck"

As seen in this Question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.