0

Today I installed Ubuntu ( along side windows 8.1 ) onto my laptop and when the computer starts up. I notice that I cannot click on the Enable Wifi. I also went into network settings and tried to turn on Wifi there but it still didn't work. It would automatically turn itself back off the results from the rfkill list are as follows blake@blake:~$rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: yes 1: asus-wlan: Wireless LAN Soft blocked: no Hard blocked: no

0

Check to see if you have module asus_nb_wmi loaded with lsmod | grep asus_nb_wmi If it is loaded try sudo modprobe -r asus_nb_wmi

sudo modprobe asus_nb_wmi wapf=4

and see if wifi can be enabled using the keyboard combo FN+F(?) If it does work you make make it persistant withecho "options asus_nb_wmi wapf=4" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf

This solution was proposed by a kernel developer on ubuntuforums

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.