1

I have a computer with a dual boot ubuntu 14.04/windows8.1. Recently, my windows screwed up and I had to factory reset it. Everything was fine: my system downgrade to windows 8 and I still had the grub to choose what operating system I'd like to use.

But as soon as I went into windows, I updated it to 8.1: that made the system boot directly to windows. Thankfully it didn't mess up with my linux partitions as I could see on GParted.

Then I put my ubuntu live usb and ran Boot-Repair. The log can be seen on http://paste.ubuntu.com/9304059/

But that didn't change anything, it boots to windows directly yet. At the end of the boot-repair setup, it shows:

Boot successfully repaired.

You can now reboot your computer. Please do not forget to make your BIOS boot on sda1/EFI/ubuntu/shimx64.efi file!

If your computer reboots directly into Windows, try to change the boot order in your BIOS. If your BIOS does not allow to change the boot order, change the default boot entry of the Windows bootloader. For example you can boot into Windows, then type the following command in an admin command prompt: bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

I ran Powershell with adm rights on windows and run the command it gave me, but it said command specifications were not valid.

How can I fix my boot?

  • your original pastbin post showed ubuntu first in boot order, but you have done some things, so check again, and repost the boot-repair if different. – ubfan1 Nov 30 '14 at 3:08
0

Go back into Windows and in the power settings, turn off fast boot. The 8.1 upgrade turns it back on, preventing a normal boot.


Also check that the INtel Rapid Start is disabled.

  • That is true, i forgot about it. But even after disabling it and running boot-repair once again, it still boots directly to Windows – Geo Nov 29 '14 at 21:17
  • I thought Dell was one of the few that still let you change UEFI boot order and boot Ubuntu. But some with Windows 8.1 says it now resets itself to be first all the time? Can you boot ubuntu entry with one time boot key, often f10 or f12, but depends on system. – oldfred Nov 29 '14 at 23:21
  • @Geo Have you changed your boot order yet? Put Ubuntu at the top of the list. – John Scott Nov 30 '14 at 1:17
  • there isnt a boot order option in my bios =( – Geo Nov 30 '14 at 3:35
0

After a couple of research I found out a solution:

sudo efibootmgr

Then check what was ubuntu boot number. In my case, it was 3, and for windows boot it was 1. (there were some other options for ubuntu and windows, but those two are the important ones)

Then type in a terminal:

sudo efibootmgr -o 3,1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.