10

I own a HP ProBook, which came with SLED11 preinstalled, and on which I has Trusty installed
(NO Dual boot). UEFI wasn't enabled. Now I bought a SSD and built it into the laptop. As I read that using UEFI can improve firmware loading time by several seconds, I enabled it and booted the Ubuntu Trusty Live USB I created with UNetBootin.

After the installation finished (erase disk and install), I rebooted and noticed that the HP boot menu said it didn't find any OS's. When I open up the Boot device selection, it lists the following:

OS Boot Manager
Boot from EFI file
ubuntu

The entry ubuntu boots my system. I can also manually specify the path to grubx64.efi. But OS Boot Manager shows above error message.

How do I get my Ubuntu automatically booted, without hitting F9 every time?

PS: The UEFI setup allows me to specify a path to a custom EFI file, if that might be helpful. However, /EFI/ubuntu/grubx64.efi doesn't work. I assume it requires some sort of device ID before it... But I's prefer putting Ubuntu in the OS Boot Manager.


Edit 1: It turns out that this is a flaw in HP's UEFI implementation. It seems that Customized Boot is the only option.


Edit 2: As soon as the HP guys tell me how to apply a firmware upgrade to my computer (refuses to load the update EFI image), I'll do so, maybe OS Boot Manager will boot Ubuntu then.

Edit 3: I learned it is not possible. To upgrade the firmware of my ProBook 455, I need to run Windows directly on it, as the upgrade image is generated locally by a Windows-only software, which reads various stuff from the BIOS, so I can neither use virtualization nor Wine.

13

The path that needs to be entered as the Custom Boot image is:

When using Secure Boot: EFI\ubuntu\shimx64.efi
When not using Secure Boot: EFI\ubuntu\grubx64.efi

This is one of two workarounds. The other would be to copy /boot/efi/EFI/ubuntu/(grub|shim)x64.efi to /boot/efi/EFI/BOOT/bootx64.efi.


Source: https://bugs.launchpad.net/linuxmint/+bug/1309395

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.