0

This question already has an answer here:

My modem Huawei e5251 works fine on Ubuntu 12.04.1 only after installing Huawei data cards Linux or mobile partner, and it's ok. Instead on Ubuntu 12.04.5 and Ubuntu 14.04 doesn't work. So I tried to follow this post. The installation goes well, the wired connection appears but there are two problems:

  • Sometimes the connection drops and it disappears from network manager (detected it on Ubuntu 14.04 64 bit);
  • In all the systems Ubuntu 12.04.5 32 bit, Ubuntu 14.04 32 bit and Ubuntu 14.04 64 bit at each reboot there isn't the connection so I forced to reinstall the driver as suggested in the post.

In my opinion, the question is not solved, because the modem is recognized but it doesn't work well. I think Huawei should update the data cards Linux driver.

marked as duplicate by muru, user68186, Mateo, Charles Green, Eric Carvalho Dec 2 '14 at 11:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • please put answers as answers, and don't put "solved" in the question, – Mateo Dec 1 '14 at 23:58
  • You should consider filing a bug report with Huawei. – muru Dec 3 '14 at 22:15