0

I'm unable to upgrade or fresh install Lubuntu 14.10 (32bit) on a Lenovo Ideapad S205.

After the install or upgrade, the laptop just boot loops. Upon booting I get the Lenovo EFI splash screen, the screen goes blank and then I'm presented with the EFI splash screen again.

At first I ran the distribution upgrade, upgrading from Lubuntu 14.04 and ran into this issue. I decided to wipe the disk and install a fresh copy of 14.10, but the same issue occurs. I can install Lubuntu 14.04 32bit without issue.

If anyone could shed some light into this, that would be great!

I suspect the issue may be with the very early EFI implementation this laptop has. I've never been able to install a 64bit non-Windows OS on this laptop, but thats a separate issue. I've tried flashing the EFI to the latest version, but that didn't resolve anything.

0

EDIT:

Hello, downgrading the bootloader brought me a functional pc.

To do that you need your install medium. Boot that up and go to your command line. Then mount your system.

sudo su
mount /dev/sdXY /mnt # XY the partition you installed / (root) (for example /dev/sda2 in my case)
cd /mnt
cp -L /etc/resolv.conf etc/ # to get the internet working
mount --bind /sys ./sys
mount --bind /dev ./dev
mount --bind /proc ./proc
chroot .
apt-get update
apt-get install grub # press 'y' when generating menu.lst
update-grub
grub-install /dev/sdX # same as before but only the device not partition
grub-install /dev/sdXY # same partition as before
update-grub
reboot

When rebooting eject your install device and your system should boot up.


Old Post:

I had the same trouble upgrading my Lenovo S205.

In my case it was from Xubuntu 14.04 to 14.10 64bit. The update process went fine, but then I got also the loop on the bios/efi bootscreen.

I managed to boot my installation with another live distro (in my case Linux Mint). For that I went to the grub console of Linux Mint by pressing 'c' when the grub boot screen comes up.

Type following commands to boot in your installed OS:

set root=(hdX,Y) # find correct partition via 'ls' (root partition, same as in following step, but they have different names (in my case this was (hd0,msdos2)))

linux /vmlinuz root=/dev/sdZ ro # the root partition of your installed OS (in my case /dev/sda2

initrd /initrd.img

boot

With these commands you should be able to boot in your Lubuntu.

I did no further investigation, but it seems the Wifi is broken again after upgrading.

I hope this helps you and sorry for my bad english.

0

Turns out it was something odd with the BIOS not playing well with anything non-windows.

Installing the customized BIOS for the S205 below and disabling UEFI boot, resolved the boot issues, including those with installing 64bit OS - https://s205blog.wordpress.com/2014/12/31/best-bios-for-lenovo-s205/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.