8

When I type xrandr and press enter, the output I get says that I have 144.0 hz available to use on my 1920x1080 resolution, but when I try "xrandr -s 1920x1080 -r 144.0" or 144 without .0 I get the "Rate 144.0 Hz not available for this size" message. I get that message with every possible refresh rate, even the current using refresh rate(60 Hz). I have nvidia-settings installed which also handles the refresh rate, might the problem be there?

10

I had the same problem with my 144hz monitor. You might try using a full set of parameters. For example, to get my 2560x1440 screen to operate at 144hz, I had to do the following:

  1. Run xrandr to find the name of your connected display output. In this case, DP-0 is my connected DisplayPort:

    $ xrandr
    Screen 0: minimum 8 x 8, current 2560 x 1440, maximum 16384 x 16384
    DVI-I-0 disconnected (normal left inverted right x axis y axis)
    DVI-I-1 disconnected (normal left inverted right x axis y axis)
    HDMI-0 disconnected (normal left inverted right x axis y axis)
    DP-0 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
    2560x1440     59.95*+ 144.00   120.00    99.95    84.98    23.97  
    DP-1 disconnected (normal left inverted right x axis y axis)
    
  2. Then use the xrandr command again with the --output, --mode, and --rate parameters. For my 2560x1440 monitor, I specified the following:

    $ xrandr --output DP-0 --mode 2560x1440 --rate 144.00
    

The monitor blinks and switches to the new rate. I'm not sure how to properly use the -s parameter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.