I am trying to re-purpose my Dell Inspiron 8600 with Ubuntu 14.04 to be used as a low scale HTPC.

Here is what I have done so far.

I have created a live USB for installation. I had to force pae to get the installation to work.

The entire installation process goes well and prompts me to reboot to finish installation. It reboots, I get to the login screen with the drums, it looks like the desktop is going to fire up and then the screen goes black and the only thing active is the mouse pointer.

I can access the terminal through Ctrl+Alt+F1. I have tried several workarounds but I honestly don't really know what I am trying and if it is making any progress. Help would be greatly appreciated.


10 Answers 10


Note: as commented by @asocia, you will need Internet connnection for this solution to work.

Sometimes your desktop may not load due to problem with lightdm.

Press Ctrl+Alt+F4 then login using your username and password. Enter the following commands:

sudo apt-get purge lightdm
sudo apt-get update
sudo apt-get install lightdm
dpkg-reconfigure lightdm

Now type sudo shutdown -r now to restart.

  • 4
    Before performing above steps, make sure you have an active internet connection. Oct 22, 2020 at 17:20

On Ubuntu 20.04 While you are in the black screen. You should do the following steps:

Press Ctrl+Alt+F4, then login using your username and password. Enter the following commands:

sudo apt purge gdm3
sudo apt update
sudo apt upgrade
sudo apt install gdm3

If it displays a warning, then choose gdm3 with arrow keys and press Enter.

If it didn't, then enter these two commands:

sudo dpkg-reconfigure gdm3
sudo service gdm3 start

Then restart from your Ubuntu login screen.

  • 1
    Worked for me even though I was on Ubuntu 18, thanks! Jul 28, 2020 at 11:16
  • I don't want to restart as I have work in progress. If I wanted to restart I'd just force shutdown the damn thing 🤦‍♂️
    – chx101
    Dec 16, 2022 at 8:14
  • Worked on Thinkpad W530 with Ubuntu 23.04. But after reboot same issue occured aggain. Just sudo dpkg-reconfigure gdm 3 and sudo service gdm3 start don't fix the issue then, but I had to repeat the full procedure again. What should I do?
    – warpfel
    Jun 12, 2023 at 8:10

It worked for me, try these steps:-

  1. From Grub menu select "*Advanced options for Ubuntu".

  2. Select the 1st "recovery mode" option ,that you see on your screen.

  3. After that you will be navigated to Recovery Menu options.

  4. In that select the 3rd option i.e. "dpkg Repair broken packages". And then enter the "Ok" button.

  5. Enter to "Yes" button.

  6. Then you will be navigated to the booting screen with 2 options 1st is "Continue [yN] and 2nd is Details [d].

  7. Type y and hit enter.

  8. Again hit Enter.

  9. You will now navigated to Recovery Menu again and then select 1st option "resume Resume normal boot". and hit "Ok" button.

  10. Again hit "Ok" button.

Now you will see your login screen with desktop background and everything works fine as it was before.

  • Works! Just if anyone is stuck at Starting user manager for UID 121 or something, hold ctrl, shit and alt f4, login and give the command reboot Jun 26, 2019 at 12:50
  • 2
    @ReeshabhRanjan *Shift mate... shift.
    – gilbert-v
    Mar 2, 2020 at 11:33
  1. Press ctrl+alt+F4
  2. Login with your user name and password
  3. use command: sudo dpkg --configure -a
  4. Now use command sudo shutdown -r now to restart the computer
  • Unfortunately, this did not work for me on Ubuntu 20.04 I still see the blinking cursor instead of the login screen.
    – HadidAli
    Jul 20, 2021 at 10:06

Try pressing CTRL+ALT+F4 and then type startx.
This is what solved it for me.


Run sudo apt-get --purge remove lightdm gdm .Be careful with this -- watch what else Ubuntu wants to remove.

In my case, Ubuntu removed gnome-core.

After it was done, I ran sudo apt-get install gnome which brought back gdm, gnome-core, etc with default configs.


On Ubuntu 16, I changed some settings in compizconfig and changed my refresh rate and when I rebooted my screen went black just with the cursor. I solved it by removing xserver and reinstalling ubuntu-desktop in the root shell:

  1. sudo apt-get purge xserver-xorg
  2. sudo apt-get purge xserver-xorg-core
  3. sudo apt-get install --reinstall ubuntu-desktop

As all above solutions did not work for me, and I need it to come back inmediately (I was writing my theis), I had to install KDE.

After all procedure I log in again selecting Plasma in the log in screen and everything works. Then I realized, that when I selected GNOME (wayland) at the log in screen, it also worked in the gnome shell. So I am not sure if by installed KDE plasma, and then changing from GDM3 to SDDM solved the problem. Maybe




Run these commands respectively:

sudo apt purge gdm3
sudo apt update
sudo apt install gdm3
sudo dpkg-reconfigure gdm3
sudo service gdm3 start
sudo reboot now

Choosing wayland on the login screen helped me

To do that you may need to install lightdm and set lightdm as default manager

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .