7

During the installation of Ubuntu Openstack - Canonical Distribution (step 4 ubuntu.com/download/cloud/install-ubuntu-openstack) I've received an error with Juju. Juju made the bootstrapping of the node, the ubuntu installer started but at the end of the procedure the node went in shut down. I've tried to resolve that editing the environments.yaml file and added the bootstrap-timeout to 3600, (all vnode use the fastpath-installer),

sudo nano /usr/share/openstack/templates/juju-env/maas.yaml

like that

default: maas

environments:
  maas:
    type: maas
    maas-server: 'http://x.x.x.x/MAAS/'
    maas-oauth: 'LnLE8w3grRK6hLcVgF:xxxxxxx'
    admin-secret: richardsith
    default-series: trusty
    authorized-keys-path: ~/.ssh/id_rsa.pub
    apt-http-proxy: 'http://x.x.x.x:8000/'
    lxc-clone: true
    bootstrap-timeout: 3600

  openstack:
    type: openstack
    use-floating-ip: true
    use-default-secgroup: true
    network: ubuntu-net
    auth-url: http://keystoneurl:5000/v2.0/
    tenant-name: ubuntu
    region: RegionOne
    auth-mode: userpass
    username: ubuntu
    password: richardsith

and then I run the command

 $: sudo openstack-install

enter image description here

enter image description here

after that the node made the reboot and during the boot I saw that

enter image description here

after some minutes the installer went head

enter image description here

the node means ready but after few seconds went down, and on .commands.log the log is this

http://paste.ubuntu.com/9284133/

I've also try to make the bootstrapping manually with debug with juju receiving the following log http://paste.ubuntu.com/9342625/

  • anyone can help me? – Riccardo Magrini Nov 29 '14 at 18:41
  • Looks like a possible error within Juju, can you pastebin the juju logs? – battlemidget Nov 30 '14 at 3:12
  • the log is reported here paste.ubuntu.com/9327941 – Riccardo Magrini Dec 1 '14 at 9:31
  • Try bootstrapping on MAAS with juju directly, without the cloud installer. That has to work before the cloud installer can be tried. – Andreas Hasenack Dec 1 '14 at 11:30
  • I tried to install and update MaaS (1.7) and Juju via ppa stable (1.7) on a clear Virtual Ubuntu server. I've added some vnode on maas, made bootstrapping of juju environment install juju-gui on a node. Everything work very well. Tomorrow I'll try to make what you've suggested me on Canonical Distribution – Riccardo Magrini Dec 1 '14 at 16:39
3

This step has been resolved extended the bootstrap-timeout to 3600 in the last upgrade of Ubuntu Openstack - Canonical Distribution. To make that run the following commands

sudo apt-get update
sudo apt-get dist-upgrade

See this link https://github.com/Ubuntu-Solutions-Engineering/openstack-installer/issues/280#event-204277001

With this solution the installer, in my lab, has continued with the procedure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.