11

My lock screen changed one day from the default: lock screen before

to this different one: lock screen after

I am running Ubuntu 14.10. The install was originally a 14.04 that I upgraded to 14.10. The lock screen did not change at that point. Since then, I've just simply been periodically installing updates and adding software packages here and there. I'm not positive but I think the lock screen changed after I installed some packages from the Ubuntu repos (might have been MuseScore) using apt-get.

This is not a big deal, but I wish I knew why it randomly changed . Any idea why it did this?

Edit: Here is the output of dpkg --get-selections | -v deinstall, as requested by Tim.

9
  • you might have installed some other desktop – Edward Torvalds Nov 28 '14 at 16:36
  • As far as I know, Unity is all that is installed. Is there a good way to find out if there are other desktop environments installed? – dagrha Nov 28 '14 at 16:56
  • Please edit your question to include more information regarding what you did between the time you had the default login screen and the new one. Random changes are unlikely and when they occur they are normally the result of A) Operator error or B) Hardware failing. – Elder Geek Nov 28 '14 at 17:14
  • Did you install unity tweak tool!? – Tim Nov 28 '14 at 17:47
  • @Tim Unity Tweak Tool is installed, but it has been installed since my original Ubuntu 14.04 install back in June or so. The new lock screen first appeared for me only about 2-3 weeks ago. – dagrha Nov 28 '14 at 18:15
13

I had the same problem. For some reasons, my "Screen Reader" option in "Universal Access" was turned on (I suspect my daughter) and was preventing the new lock screen to kick in.

Apparently, "on-screen keyboard" option could also cause this behaviour as suggested in this thread:

How to restore the new 14.04-lockscreen

I suggest you check in System Settings > Universal Access to see if you have any option enabled that could be the cause of the problem.

Good luck

3
  • Bingo. Indeed, my "Screen Reader" was turned on. I'm wondering if that got toggled on when I accidentally ran the Orca screen reader about the time the lock screen changed on me. I turned the Screen Reader off, and the Lock Screen is back to the default one. Thanks for your answer! – dagrha Dec 18 '14 at 1:30
  • Thanks, this was the issue for me, too. It turns out that if you accidentally press the key combination Alt+Super+S, the screen reader is activated. I suspect this is what I did to cause the setting to change. – James Womack Jan 27 '16 at 11:25
  • On screen keyboard was activated and disabling it fixed this issue for me, thank you. – MaxiWheat Oct 30 '18 at 13:23
6

Both the lock screen exist in your system. The first one is provided by Lightdm, you can try

dm-tool lock

The second one is provided by gnome, use

gnome-screensaver-command -l

To set dm-tool as your desired lock screen install, compizconfig-settings-manager

sudo apt-get install compizconfig-settings-manager

Go to CompizConfig Settings Manager, click on Ubuntu Unity Plugin and on the General tab, under Lockscreen, you can select LightDM lockscreen.

enter image description here

webupd8 described how to switch between unity and lightdm lock screen.

9
  • He want's the default to be the gnome one. How can that be done? – Tim Nov 28 '14 at 18:57
  • 1
    @souravc, using dm-tool lock did indeed lock to the Unity lock screen! However, when I unlocked from that screen, it unlocked to the Gnome lock screen...at which point I need to enter my password to unlock a second time... To my knowledge I don't think I ever installed Gnome. I wonder why I am getting Gnome's lock screen? – dagrha Nov 28 '14 at 19:10
  • @dazzle it is very difficult to find out the reason, have you recently installed/modified anything? – sourav c. Nov 28 '14 at 19:32
  • @souravc, the "webupd8" link in your post just goes to imgur. I installed the CompizConfig Settings Manager like you recommended-- the "General" tab looks axactly like the screen shot you posted, except without the lock screen option... See this screencap – dagrha Nov 28 '14 at 19:35
  • @dazzle I have updated the link, see now – sourav c. Nov 28 '14 at 19:36
0

i also have the same problem. read about it on other pages too but couldn't find a solution. neither by terminal commands. finally i find a solution. i turned off the on screen keyboard from the Universal access -> Typing menu and i got my old dm-tool lock screen. This worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.