24

when launching mysql-workbench I have the following warning:

[12:13:49] coil@coil:~$ sudo mysql-workbench &
[12:14:03] coil@coil:~$ ** Message: Gnome keyring daemon seems to not be available. Stored passwords will be lost once quit
[12:14:05] coil@coil:~$ Ready

Is there a way to fix this issue? Indeed, my passwords never get saved.

2
  • What Ubuntu version/release it this on? Cuz ... bugs.mysql.com/bug.php?id=61170
    – Rinzwind
    Nov 28, 2014 at 14:45
  • Sorry guys, I'll try all you suggested me soon. Thanks for the help. ;)
    – COil
    Dec 25, 2014 at 22:10

9 Answers 9

30

The bug has been fixed in MySQL Workbench 6.2.5 / 6.3.0 releases. http://bugs.mysql.com/bug.php?id=74771

A possible workaround was to add this code to the top of file /usr/bin/mysql-workbench

export GNOME_KEYRING_CONTROL=1

This fix work on my ubuntu 14.04 with MySQL Workbench community 6.2.4 from deb http://repo.mysql.com/apt/ubuntu/ trusty workbench-6.2

2
  • Thanks for linking the issue and providing the workaround - this is the cleanest approach! May 19, 2015 at 20:25
  • 3
    Using V6.3.6 error still persists
    – Matiss
    Aug 9, 2016 at 8:17
15

There's a neat way I found, try this out.

Step 1: After installation unlock the workbench icon from launcher.

Step 2: press the super(window) button on your machine and search for workbench.

Step 3: Open workbench from the search results.

Step 4: Once open, lock the workbench icon to the launcher.

Voila !!! The keyring problem disappears.


3
  • 2
    Thanks.. Much Cleaner way to resolve this issue. Thanks a ton. :) Apr 28, 2016 at 3:34
  • 1
    Works but an explanation would be nice...
    – snorbi
    Dec 23, 2016 at 9:09
  • 1
    Wow! I just realized that I always was launching workbench from dash (start menu) but not from launchbar. And now today after few years of using workbench launched it by clicking on launcher and got that problem!
    – Dimitry K
    May 9, 2017 at 14:12
9

This answer is a variation on the guest1000's solution, but I don't have enough rep to create a comment.

Anyway, adding the following to ~/.bashrc also works and seems cleaner to me:

export GNOME_KEYRING_CONTROL=$(ls -d /run/user/1000/keyring-*)
6

Add this code to the top of file /usr/bin/mysql-workbench

if ls /run/user/`id -u`/keyring-* 1> /dev/null 2>&1; then
    gnome-keyring-daemon > /dev/null
fi

export GNOME_KEYRING_CONTROL=$(ls -d /run/user/`id -u`/keyring-* | head -n 1)

It's not clean solution, but it works. No need of running workbench from terminal.

5

I did as follows i am using Workbench 6.3

sudo gedit /usr/bin/mysql-workbench

Just remove the comment

@line 5

WB_NO_GNOME_KEYRING=1 
3

I am using Ubuntu 18.04. The simplest way I found is

  1. Go to Ubuntu software center.
  2. Search for MySQL workbench community.
  3. Click on permission
  4. Enable Read, add .... to on
2
  • Thanks worked for me
    – Fahim
    Jun 7, 2020 at 22:34
  • This is the most correct solution for snap users. Oct 7, 2020 at 5:55
2

mysql-workbench is looking for the GNOME_KEYRING_CONTROL environment variable. If you are the only one using your computer, that variable should have a value similar to /run/user/1000/keyring-XXXXXX.

I had a similar problem with mysql-workbench package downloaded from dev.mysql.com (because MariaDB and Ubuntu's mysql-workbench package are incompatible) and a simple custom shortcut with the following launch command fixed the problem:

GNOME_KEYRING_CONTROL=$(ls -d /run/user/1000/keyring-*) /usr/bin/mysql-workbench
1
  • no need to do as long as this. just type mysql-workbench from terminal
    – akikara
    Dec 17, 2014 at 20:39
2

The most stupid issue ever seen!

if you start your mysql-workbech by launcher this error comes out.

But if you start your mysql workbench from terminal keyring problem disappears.

Any ideas why this is happening? I was using version 6.0 and upgraded to 6.2.4 nothing changed. The workaround answer for this issue is Go terminal and start stupid workbench by Oracle...

1
  • I am having this issue and its 2017 Dec 11, 2017 at 11:53
0

Ubuntu 20.04 LTS

I just:

  • Removed mysql-workbench.
  • Downloaded mysql-workbench deb package from the official mysql page.
  • Installed it with dpkg and it solved my problem.

I guess the problem was that I installed mysql-workbech with snap.

2
  • I would be very surprised if you had encountered the very same problem from 2014.
    – guntbert
    Aug 7, 2020 at 20:05
  • The snap works, the issue is with permissions. Have a look at Amrit's answer Oct 7, 2020 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.