3

i've followed the Marco Ceppi guide (http://marcoceppi.com/2014/06/deploying-openstack-with-just-two-machines/comment-page-1/#comment-70358) about how to deploy openstack on just 2 node. I tried to re-create that on a virtual environment using KVM as hypervisor and 4 vnode both of them on the same vnet. On these node I've installed the environment in this way:

  • vnode 0 juju-gui
  • vnode 1 mysql,keystone,nova-cloud-controller,glance,rabbitmq-server,openstack- dashboard,cinder
  • vnode 2 nova-compute

all nodes are Deployed and run perfectly, juju idem. The all relations are made and in green status,all service are explose.

enter image description here

Horizon has worked just one time, after the reboot of all nodes if I try to open Horizon receive this error

"This webpage is not available"

enter image description here

I've also tried to restart apache on node but nothing. As Marco requested me here the pastebin of this file

http://paste.ubuntu.com/9441299/ and http://paste.ubuntu.com/9441304/

  • anyone can help me? – Riccardo Magrini Nov 28 '14 at 14:31
  • Can you pastebin the output of sudo initclt list and ps -aef from the horizon node and edit your question to include this new content. – Marco Ceppi Dec 5 '14 at 17:21
  • as your requested I've added that output – Riccardo Magrini Dec 9 '14 at 12:52
  • Can you run the following and then check if horizon is working? sudo a2ensite horizon and sudo service apache2 restart – Marco Ceppi Dec 10 '14 at 1:10
  • the result of the command is not good paste.ubuntu.com/9457273 horizon does not exit!!! why? – Riccardo Magrini Dec 10 '14 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.