3

I am using Ubuntu Gnome 14.10 64 bit on Dell Inspiron 3521. I have ATI Radeon 7560M HD Series Graphics Card. I tried installing ATI Graphics card in different ways.

1)Selecting fglrx from Additional Drivers under Software & Updates section

2)Selecting fglrx-updates from Additional Drivers under Software & Updates section

3)Downloaded latest ATI Driver (amd-catalyst-14-9-linux-x86-x86-64.zip) from AMD website and installed it.

Before trying every option, I uninstalled older drivers completely.

In every option, after reboot, all I got is a text console. Couldn't able to get into Display at all. Is there any driver working for Ubuntu Gnome 14.10 ? How can I get it and install it ?

The primary reason for me installing is the battery backup. Its hardy 40 mins on Ubuntu where as its 4+ hours on Windows. I want to install ATI Graphics card driver and disable the Discrete graphics card and enable only Intel graphics card so that battery back up will be better.

Please help. Thanks in Advance.

Update: This is the error I am getting

/usr/bin/X: symbol lookup error: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/extensions/libglx.so: undefined symbol: LoadExtension

Xinit: giving up

Xinit: unable to connect to X server: Connection refused

Xinit: server error

Update2 : Tried amd-catalyst-omega-14-12-linux-x86-x86-64.zip but no luck

  • did you disable secure boot ? last time I installed the ati driver I had to disable secure boot in my bios. otherwise , what error message are you getting in the logs ? – Panther Nov 27 '14 at 3:45
  • Yes secure boot is off. I don't have an option to disable ATI driver in my bios. – mac Nov 27 '14 at 6:54
  • I am using Ubuntu Gnome. It has only gnome-shell and no unity – mac Nov 27 '14 at 18:41
  • can you log in as another user ? – Panther Nov 27 '14 at 18:46
  • Tried. Not much difference – mac Nov 28 '14 at 10:40
0

You're seeing the symbol lookup errors because the amd-catalyst-14-9-linux-x86-x86-64.zip and amd-catalyst-omega-14-12-linux-x86-x86-64.zip packages are only compatible with the LTS releases, 12.04 and 14.04. So one option would be to downgrade from 14.10 to 14.04.

However, the release notes for the RUN installer indicate that it is compatible with 14.10. It is a more complicated install, but with the driver being built for your system you won't get symbol lookup errors.

Before you start, be sure you have all of the build dependencies:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases 

Then download amd-catalyst-omega-14.12-linux-run-installers.zip and follow AMD's installation instructions.

0

Try this:

Edit your GRUB file /etc/default/grub

old: GRUB_CMDLINE_LINUX="" fix: GRUB_CMDLINE_LINUX="nomodeset"

and save & exit.

$ sudo update-grub
$ sudo reboot    ### you need to reboot before doing next command
$ sudo apt-get install -y fglrx-update* --reinstall
$ sudo apt-get update
$ sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.