1

I really like Ubuntu, but one minor annoyance I've always had with it is that, when using a web browser that places its tabs at the top of the application (Chrome in my case, though Firefox does this too), the unity panel (bar at the top of the screen) prevents the browser tabs from being placed at the very top of the screen. This makes it marginally more difficult for me to position my mouse over the tabs, as I have to worry about my mouse's vertical positioning instead of just pushing it all the way to the top of the screen as I do on Windows.

Is there a way to hide this annoying bar or move it to the bottom of the screen so my browser tabs can utilize that valuable piece of screen real-estate instead of it being wasted on menu items I rarely use? (Or alternately, a solution like this would also be acceptable.)

  • Hmm, this might be a duplicate of How can I move the panel from the top to the bottom?. Actually, it's more of a superset than a duplicate, but the answers to that question do answer at least part of what I was asking. – Ajedi32 Nov 25 '14 at 22:05
  • you can install Cairo dock. when you login, you can select cairo-gnome session instead of unity/ubuntu. in cairo-gnome session unity-launcher is gone/removed – Edward Torvalds Nov 25 '14 at 23:44
  • OR you can install Gnome desktop from Ubuntu software. like mac gnome desktop's panel is at top unlike unity launcher which is on left – Edward Torvalds Nov 26 '14 at 3:04
  • Also, the browser tabs merge into the top panel on the unity desktop, this is one of the best unique features of unity. All you have to do is use the "global menu" I think it is called. – mchid May 7 '17 at 0:36
1

That feature is not available on the unity desktop. You can, however, install another desktop environment.

lubuntu-desktop, gnome-session-fallback, xubuntu-desktop, and ubuntu-studio-desktop offer either autohide or in the case of gnome-session fallback there is a hide function you can click an arrow to hide the top panel.

For ubuntu-studio, xubuntu, and lubuntu you can right click on the panel, choose panel properties and there should be an autohide function somewhere in the options.

  • After the news about end of unity life, I've switched to Xfce. It can be made look like unity and is feature rich. It is worth to test it at least one time specially when you have such problem with unity. – Hamed May 6 '17 at 21:40
  • @Hamed Actually, XFCE already is my second choice for desktop after Unity. On Ubuntu, I really like UbuntuStudio which is XFCE and Xubuntu isn't bad as well. I like to use XFCE on Debian and Arch. It looks like the community will continue to support Unity as a Compiz plugin as Compiz itself is a fork and stuff like CCSM is already community supported so I hope Unity7 will continue to see another day or at least Compiz so that we can still have the Compiz Cube on XFCE! – mchid May 7 '17 at 0:34
0

Press F11 in the browser to put it in full screen mode.

  • That hides the browser tabs too, which kind of defeats the whole purpose of hiding the unity panel in the first place. – Ajedi32 Nov 25 '14 at 23:30
  • A bit late, but in Firefox you can deactivate "Hide Toolbars" when in full screen mode and right clicking on the toolbar. – Andreas Hacker Sep 28 '16 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.