2

As the title suggests, I upgraded my Dell XPS 15 laptop to 14.10 and now the brightness is stuck at the lowest level. The fn+F4/F5 displays the brightness notifications but the brightness level of the screen does not change.

Things I have tried that did not help:

Switching from Nvidia drivers to Nouveau did not help.

xrandr does increase the gamma a tiny bit:

 xrandr --output "LVDS1" --brightness "1"

Many questions suggest either adding or subtracting acpi_backlight to your /etc/default/grub file, which did not help either:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor splash"

I also tried writing directly to the brightness file:

echo 4000 | sudo tee /sys/class/backlight/intel_backlight/brightness

There seem to be many questions of this type:

Automatic screen brightness on Ubuntu 14.10 not working right, manual controls not working at all

Can't control laptop screen brightness after upgrading to 14.10

Hot keys brightness issues with Ubuntu 14.10 in Acer Aspire 5755

Toshiba u840: Hotkeys don't work after upgrading to 14.10

Unable to change screen brightness with hotkeys on Ubuntu 14.10

Upgraded to 14.10, brightness control quit working - Intel HD 4400

Which package should I be looking at to file a bug? What information would help?

Does anyone have a solution I should try that is not listed above?

Update: Booting from a live USB (I think it was 13.04) reset the brightness to the maximum. Booting back the 14.10 the screen stayed bright, but the brightness controls still don't do anything. Feels like progress. :)

  • 1
    have you tried askubuntu.com/a/552526/16395 ? – Rmano Nov 25 '14 at 20:31
  • The xrandr method has always screwed up the coloring of my screen without actually changing the real brightness. If you are using an nvidia connected display with either nouveau/nvidia driver, then xbacklight should work fine (might need to install). On my machine I wanted more finely tuned backlight steps than the defaults so I mapped the brightness +/- keys to the commands xbacklight -inc 1 and xbacklight -dec 1 – theferrit32 Nov 25 '14 at 20:32
  • I tried xbacklight and acpi_osi=Linux, but neither of them seem to have any effect. Any other thoughts are appreciated. – mikewilliamson Nov 25 '14 at 20:51
  • Do you have file called 20-intel.conf in /usr/share/X11/xorg.conf.d/ ? – m1nev Nov 28 '14 at 20:05
  • No I don't. The Dell XPS 15 is one of those Nvidia Optimus setups: an Nvidia card hidden behind the Intel onboard graphics. Should I have a 20-intel.conf in that scenario? – mikewilliamson Dec 1 '14 at 17:15
2

In the terminal:

sudo gedit /etc/default/grub

Change

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

Save, then

sudo update-grub

Restart computer.

The function keys (fn+F5/F6) should now be active.

  • This worked for me with Ubuntu 14.10 on a Dell XPS 14" – Floby Apr 3 '15 at 8:29
  • This worked for me too on a Dell XPS 14 L421X and Ubuntu 15.04 – Benoît Bouré Sep 11 '15 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.