I have installed the new Ubuntu 14.10 on my Dell Inspiron 3521.

I was able to use my wifi in the Boot Live Stage and during the Installation phase by enabling the BroadCom BCM 43142 proprietary drivers.

But after installation I can't enable the proprietary drivers.

I can see the drivers listed there and when I select the option to use them and click Apply, the progress bar starts going ahead but stops in process and the 'Do not use them' option gets reselected.

I have searched some questions here according to which I must connect my laptop with an ethernet cable to get my wifi drivers working.

But I don't have any ethernet cable at present with me. I can only use the wifi on my second laptop.

Is there any other way to get the drivers working or Is there any offline installer like a .deb file for the drivers?

If anyone knows, please help!

I've reinstalled ubuntu thrice but the problem remains same.

Do you still have the install USB or DVD? Insert it and drill down to pool > restricted > b > bcmwl and drag bcmwl-kernel-source to your desktop. Do the same with pool > main > d >dkms and drag dkms to you desktop. Then install:

cd ~/Desktop
sudo dpkg -i dkms*.deb
sudo dpkg -i bcmwl*.deb

Reboot and tell us if your wireless is working.

  • This is a better solution then with tethering. – Mateng Sep 29 '16 at 15:48

I also have the same wifi driver and i too was unable to use the driver after a fresh install. I was not able to make an offline install, but here is another way your problem may be solved. Using USB tethering, you can use you mobile internet connection (you can use either wifi or data pack, any of them will do) to access the internet. I was able to install my driver using these commands

sudo apt-get install linux-firmware-nonfree
sudo apt-get update

this will build repositories, not all update is required. Then update the Ubuntu list of PCI.IDs:

sudo update-pciids

And finally install the driver

sudo apt-get install bcmwl-kernel-source

Before ubuntu 14 only one command was required to install the driver, but in ubuntu 16, these two things are required and initially internet is required:

sudo apt-get update
sudo apt-get install bcmwl-kernel-source
  • For a fresh install (14.10, 15.04), you need to run sudo apt-get update first, before attempting to load linux-firmware-nonfree. – david6 Apr 25 '15 at 3:30
  • Confirmed works also 15.04 (64-bit). – david6 Apr 25 '15 at 5:01
  • Confirmed works, for 14.04.2 LTS (64-bit) and 14.10 (64-bit). – david6 Apr 26 '15 at 4:37
  • Many many thanks!!! – Vaggelis_Z Jan 24 '16 at 18:44

I had the same problem, here is how I resolve it (offline) on Ubuntu 14.04:

  1. Download the driver: http://www.lwfinger.com/b43-firmware/broadcom-wl-5.100.138.tar.bz2

  2. Switch to Ubuntu, install the b43-fwcutter package which is located on the Ubuntu install USB/CD (on the Terminal):

    cd /Your_Usb_CD_Drive/pool/main/b/b43-fwcutter/
    sudo dpkg -i b43-fwcutter*

  3. Copy the file (broadcom-wl-5.100.138.tar.bz2) to your home folder. Open the Terminal (go to your home folder and) use b43-fwcutter to extract and install the firmware:

    tar xfvj broadcom-wl-5.100.138.tar.bz2
    sudo b43-fwcutter -w /lib/firmware broadcom-wl-5.100.138/linux/wl_apsta.o

  4. Restart the computer

I got it from the following link: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx#Top

I was able to do this with Ubuntu 15.04 Mate by...

  1. Turning off all sources in System>Preferences>Other>Software & Updates in the Ubuntu Software, Other Software, and Updates tabs.
  2. Check the box under Installable from CD-ROM/DVD
  3. Now make sure the CD you used is inserted. If you used a USB drive, you will need to make a symbolic link to trick the system into thinking your USB installation media is a CD by running sudo ln -s /media/$username/Ubuntu-MATE\ 15.04\ amd64/ /media/cdrom but be sure to replace $username with your actual username like bob.
  4. Now run sudo apt-get install bcmwl-kernel-source and press enter when prompted.
  5. You'll want to remove the symbolic link after you verify that this worked. To do this, run sudo rm /media/cdrom then you will want to disable the CD-ROM/DVD repository and enable the other repositories that you disabled in

My BCM43142 wireless adapter on my HP Stream began working nearly immediately. I hope this helps!

protected by Community Aug 25 '15 at 8:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.