1

Let me start with a disclaimer: I have tried to fix my problem by reading similar questions & answers, but so far no luck. Not only that, but I think that by making some changes to resolvconf I have messed it up further. I need someone to take me by the hand and help me fix this issue, I would be immensely grateful!

The situation is this: I am living in a building where the internet is provided by the university's network. Recently, some upgrades where done to the network, after which all my connectivity issues arose.

My Windows desktop PC will connect properly when using the same connection, no issues there. MY 14.04 ubuntu laptop, however, shows a normal connection to my router (wired or wirelessly, both work) but I am then unable to browse to any webpage.

Symptoms: - Can ping IP addresses but not websites (DNS issues?) - I can ssh to a server that I know is based at the university, so on the same network, and through there, I can use firefox to browse.

In case those are helpful, I will post below the output of ifconfig, and the contents of /etc/resolv.conf, which I think needs to be completely reconfigured after my failed attempts.

ifconfig:

eth0      Link encap:Ethernet  HWaddr b8:88:e3:84:1a:0e  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:12843 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12843 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:826185 (826.1 KB)  TX bytes:826185 (826.1 KB)

wlan0     Link encap:Ethernet  HWaddr 20:68:9d:74:97:54  
          inet addr:192.168.2.100  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::2268:9dff:fe74:9754/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:216847 errors:0 dropped:0 overruns:0 frame:0
          TX packets:194916 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:40559273 (40.5 MB)  TX bytes:25893877 (25.8 MB)

Content of /etc/resolv.conf:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
nameserver 8.8.8.8
nameserver 8.8.4.4

EDIT: nm-tool output:

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            alx
  State:             unavailable
  Default:           no
  HW Address:        B8:88:E3:84:1A:0E

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         off


- Device: wlan0  [ICIDU] -------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             connected
  Default:           yes
  HW Address:        20:68:9D:74:97:54

  Capabilities:
    Speed:           1 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    wifiwifi:        Infra, C0:4A:00:84:6B:5C, Freq 2422 MHz, Rate 54 Mb/s, Strength 25 WPA2
    Sitecom1E55CA:   Infra, 64:D1:A3:1E:55:CA, Freq 2472 MHz, Rate 54 Mb/s, Strength 17 WPA2
    VosHotSpot:      Infra, 00:23:54:08:02:8A, Freq 2412 MHz, Rate 54 Mb/s, Strength 29 WEP
    Pritty fly for a wifi: Infra, 08:60:6E:E2:93:50, Freq 2437 MHz, Rate 54 Mb/s, Strength 15 WPA2
    @Home41596:      Infra, 00:14:6C:9A:D4:5C, Freq 2437 MHz, Rate 54 Mb/s, Strength 14 WPA
    Pauw2:           Infra, 00:1C:10:2F:B3:3C, Freq 2462 MHz, Rate 54 Mb/s, Strength 7 WPA
    belkin54g:       Infra, 00:17:3F:46:FF:7A, Freq 2462 MHz, Rate 54 Mb/s, Strength 5 WPA
    Sitecom057D42:   Infra, 64:D1:A3:05:7D:42, Freq 2447 MHz, Rate 54 Mb/s, Strength 19 WPA2
    Indigo Plateau:  Infra, 00:0C:F6:55:BE:B8, Freq 2462 MHz, Rate 54 Mb/s, Strength 17 WPA
    NZ:              Infra, 48:F8:B3:28:C2:09, Freq 2462 MHz, Rate 54 Mb/s, Strength 5 WPA WPA2
    MAX-PC_Network:  Infra, 6C:FD:B9:53:CA:68, Freq 2427 MHz, Rate 54 Mb/s, Strength 10 WPA WPA2
    *ICIDU:          Infra, 80:1F:02:A4:9E:BC, Freq 2462 MHz, Rate 54 Mb/s, Strength 89 WPA2
    Zadnuk:          Infra, 00:01:E3:C3:C0:61, Freq 2437 MHz, Rate 54 Mb/s, Strength 15 WEP
    Studententehuis: Infra, 98:FC:11:B1:AC:99, Freq 2462 MHz, Rate 54 Mb/s, Strength 7 WPA2

  IPv4 Settings:
    Address:         192.168.2.100
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.2.1

    DNS:             192.168.2.1

Cheers, ArcM

  • 1
    Hard to know . The file /etc/resolv.conf reads clearly "DO NOT EDIT THIS FILE BY HAND" . You configure your network, and dns server, witn network manager, which is a graphical tool. Your problem, however, may be that you firewalled DNS, I am not really sure. – Panther Nov 25 '14 at 2:22
  • You can restore the default resolvconf simply by running sudo apt-get --reinstall install resolvconf. As for your network problems the only support I can give is to tell you I have encountered the exact same problem and am yet to find a solution. – jessenorton Nov 25 '14 at 2:31
  • @jessenorton - Not necessarily .... and 8.8.8.8 and 8.8.4.4 are both google and both work, so not really the problem. – Panther Nov 25 '14 at 2:52
  • What does nm-tool tell us? – chili555 Nov 25 '14 at 3:08
  • 1
    @jessenorton - sudo apt-get doesn't work, probably because it cannot reach archive.ubuntu.com – ArcM Nov 25 '14 at 9:28
0
  • Keep your network cable plugged in.
  • In Network Manager disconnect from your network
  • Set /etc/resolv.conf to these 3 lines:

    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    

(Note: 127.0.0.1 instead of 127.0.1.1)

  • In Network Manager connect to your wired network

Once you do that DHCP should pick up the right configuration - pretty much the same way Windows computers do.

Edit

It looks like your dnsmasq is somehow broken. dnsmasq is a local caching name server, it remembers the IP addresses of web sites and next time you request them it provides the answer rather than the request going to the network name server. To verify whether this is the case edit file /etc/NetworkManager/NetworkManager.conf and comment out (put # in front of) line dns=dnsmasq. Then use NM to disconnect from your wired connection and connect again. Let us know what happens.

  • 1
    @sMurf - Thank you for your reply. I followed your steps, and for a literally a couple of seconds everything seemed to be fixed. But a few seconds later I tried refreshing www.youtube.com and everything was broken again. I went back to the /etc/resolv.conf, and it has been changed again to 127.0.1.1 automatically. – ArcM Nov 25 '14 at 9:21
  • and thus the "DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN" . As I said before, you configure your DNS server with network manager. 127.0.1.1 is the same as 127.0.0.1. and as I said before , the problem is not the ip address(es) of the dns servers as 8.8.8.8 and 8.8.4.4 are public DNS servers. I am guessing firewall, but hard to tell. Could be a proxy. – Panther Nov 25 '14 at 13:12
  • For information on setting a dns server see askubuntu.com/questions/130452/… , but again, I do not believe the problem is with the ip address of dns servers. – Panther Nov 25 '14 at 13:57
0

I had the exact problem. I could connect with win7 machine, but i could not connect with ubuntu 14.04 machine with university network although i had adjust the same setting.
After 2 days examine, I understood that automatic proxy settings does work on win7 machine but it does not work on ubuntu.

So, first you need to find an internet connected machine and type

chrome://net-internals/#proxy

in the google-chrome address bar. Under effective proxy settings headline you should see Pac script address. Please note down this address.
You should click system Settings->Network->Network proxy in Ubuntu machine. After you should select Automatic as Method, you should type pac script that you have just notted.
And last, you should click Apply system wide button.
After reset the connection, you can reach internet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.