0

EDIT: I finally realized that there are two different versions of Linux listed in the Grub booting menu

  • 3.13.0-39
  • 3.13.0-32

If I pick 3.13.0-32 the keyboard and mouse will work. But if I pick 3.13.0-39 I have no mouse or keyboard.

Last week I installed Ubuntu 14.04 on a Dell Optiplex 760. The whole install worked fine and I started getting everything on the machine set up to my liking (installing chrome, email client, mapping a shared drive). I rebooted several times during this process and had no issues.

I come back to it this morning and now I cannot get any keyboard or mouse to do anything inside of Ubuntu. I have tried different keyboards/mice and different USB ports all with no effect.

While the machine is booting up it does recognize keyboard and mouse because I can use them to press F2 which will take me to the BIOS and then I can navigate around the BIOS with both mouse and keyboard. So I know all of the hardware is working fine.

Searching around online I've found a lot of stuff talking about VT-d and enabling IOMMU but I don't see any option for anything by either of those names in the BIOS and I don't know enough about either of them to even know where else to start looking.

Since I can't get keyboard or mouse working I can't run any commands to help with diagnostics.

However I am able to boot from the install CD and alter files on the hard drive. I tried adding intel_iommu=soft to the file /etc/grub.d/40_custom based on a suggestion I found while searching for this issue and device model #. That does not seem to have had any effect though to be honest I am not certain I actually put it in the right spot.

Does any one have suggestions for further diagnosing or solving this issue so that I can correctly use mouse / keyboard on my machine?

0

I have had same problem whit mouse, and you could try to enter in the terminal this:

 gsettings set org.settings.gnome-cursor cursor=false

and for the keyboard enter this in the terminal:

 gsettings set org.settings.gnome-keyb keyb=true

and it might work fine this way.

  • I will try it out tomorrow, thanks for the suggestion. – FoamyGuy Nov 24 '14 at 22:53
  • Did not work unfortuantely – FoamyGuy Dec 4 '14 at 18:50
0

There has been another new version of the kernel 3.13.0-40 which resolved the issue. Once my ubuntu updated to this new version everything went back to working correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.