0

I'm trying to follow the instruction here https://communities.vmware.com/thread/390022?start=30&tstart=0 to create a PXE boot client over PXE Server I'm able to deploy the server and the client is work as expected.

The thing that remain is enable sound, I'm not able to enable it. I have try a lot of thing but it still not working.

apt-get install alsa-base
usermod -a -G audio view
apt-get install alsa-utils --reinstall

not working also I have follow the instruction here //help.ubuntu.com/community/SoundTroubleshooting

Also here //wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS using DKMS but still not working

And I'm also go through the troubleshoot here //help.ubuntu.com/community/SoundTroubleshootingProcedure and also have no progress.

I'm not ubuntu expert. I have spent almost 16 hours on this. searching around but still can't find a way to get it work.

I'm using 2 Virtual Machines for Server and Client. I'm using Xfce.

sudo aplay -l
#give me 
aplay: device_list:268: no soundcards found...

I'm using 14.04.1 for the server and client with the kernel 3.13.0-32-generic I'm sure the Virtual machine sound card is supported by Ubuntu, because I have try to install the Ubuntu 14.04.1 Desktop on the Virtual Machine and it can play sound. So look like I missing something. I'm using VMware vsphere 5.5 for both virtual machines (PXE server and client)

Really hope somebody can show me the way to get it work.

Update: lspci output. I'm using VMware Workstation 9.0 for the pxe client

view@pxe_client:~$ lspci -v | grep -A7 -i "audio"
02:02.0 Multimedia audio controller: Ensoniq ES1371 /Creative Labs CT2518 [AudioPCI-97] (rev 02)
        Subsystem: Ensoniq AudioPCI 64V/128 / Creative Sound Blaster CT4810
        Physical Slot: 34
        Flags: medium devsel, IRQ 9
        I/O port at 2080 [size=64]
02.03.0 USB controller: VMware USB2 EHCI Controller (prog-if 20 [EHCI])
        Subsystem: VMware US2 EHCI Controller
        Physical Slot: 35
  • Does the VM even have an emulated sound card? lspci? – CL. Nov 24 '14 at 14:59
  • Yes, I create 2 machine 1 for pxe boot, and 1 for install ubuntu 14.04.01 Desktop. The pxe boot not work, the ubuntu 14.04.01 Desktop have no problem – Yuan Chen Nov 24 '14 at 16:32
  • And the lspci output? – CL. Nov 24 '14 at 17:00
  • Hi, I have updated my lspci output on the question. – Yuan Chen Nov 25 '14 at 3:20
  • And is the snd-ens1371 module configured in your kernel, and loaded? – CL. Nov 25 '14 at 7:39
0

The problem is I missing some package check this out https://help.ubuntu.com/community/LiveCDCustomizationFromScratch

  • That link contains a lot of info about a lot of things, are there any specific parts we should be focussing on to get the sound card recognised? – Rob Evans Jun 10 '16 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.