1

I have been having a tough time setting up an environment to run a specific software in and it has come down to getting a fresh HDD to install linux on. I am trying to modify a software called Cura specifically the CuraEngine. It was developed under linux and has dependencies that I could not fulfil on windows (from what I understand). So I am specifically installing a linux based system. I then need to install CUDA; I have a Nvidia 750Ti installed in the machine. I plan to write some kernels to accelerate the 3DModel -> G-code generation process for the project.

I have tried quite a few times now to get this working but the process always breaks down after I install the nvidia drivers. I have been using the method described here to install along with trying from the CUDA toolkit download. For the second method I have had to shutdown lightdm and run the .run from the command line to get the drivers installed. All attempts have been from fresh installs of Ubuntu also.

Each attempt results in the driver being installed (from what I can tell, no errors upon install), but upon restarting the computer and a login the background of the desktop and the mouse appear but nothing else, I can Ctrl+Alt+F1 to a terminal. Worth noting right now maybe, that before the drivers are installed the shortcut Ctrl+Alt+F1 displays a black screen but after the install and a reboot it works though I can't login properly. So I assume the driver has been installed and is running but I am not sure how to check properly. I ran the command in step 5 of the install guide I'm using but my machine did not display the desired result of "Kernel driver in use: Nvidia".

To try and fix this issue I tried to use sudo apt-get purge nvidia-current and rebooted but still couldn't login. I also tried unity --replace and received errors pertaining to an "OpenGL module".

I currently am now at the point of an install seen below, also under "System -> Software & Updates -> Addditional Drivers" it shows no additional drivers. enter image description here

Now this is the point at the install that I would restart and try to log back in and see if NSight Eclipse would recognize my GPU as a CUDA enabled device. But I am afraid I will not be able to log back in as usual.

In there something I can do right now that would be easier than essentially blocking myself out? Why am I being blocked out? What should my next steps be?

EDIT: Because I can use Ctrl+Alt+F1 to get to a terminal I also managed to install ccsm and set the unity plugin to installed, which failed to solve the problem. But as I tried to find the link I used I found this link and it looks like it might solve the problem of seeing the desktop. I am going to try it.

I also just realized that I can probably re-run the test in step 5 of manual linked above to check if the driver installed worked after the reboot.

EDIT2: Running the command dconf reset -f /org/compiz/ from the first edit displays an error from "Cannot autolaunch D-Bus without X11 $DISPLAY". As for the tests from the 5th step. On the first the output from the lspci -vnn | grep -i VGA -A 12 is too long and I am not sure how to scroll up I'm a newb. For the second glxinfo | grep OpenGL | grep render returns an error "Unable to open display".

I am not sure what the command specifically does but I have seen it in some of the links today export DISPLAY=:0. I ran this and then ran the dconf reset -f /org/compiz/ successfully but setsid unity errors saying "Plugin opengl not loaded, Plugin init failed: unityshell" ... " Compiz (opengl) - Fatal: glxQueryExtensionString is NULL for screen 0".

0
1

Looking at the questions you've already asked in the past and the answers you've already given, I deduce you're primary a windows user who needs specific help with NVidia development. (Please correct me if I'm wrong)

Xorg/edgers is the bleeding edge for NVidia, so you are installing drivers that are in beta (or worse) and you might run into problems using them. On the other hand, they give you the flexibility you apparently need. This is advanced stuff and frankly, you're a computer wiz under Windows but you should not forget you're a newbie under Linux! (You are now where I was about 9 months ago.)

So take a less "let's first install all this stuff and see what happens" and more a "let's install one single thing and see if that works" approach:

First of all, install plain vanilla Ubuntu. That works? Clonezilla Disk to Image file your Ubuntu partition so you can roll back. Now install xorg nvidia latest drivers and play a few games, open a few spreadsheets and see whether it works. If it does not, use xorg/edgers to install a previous driver and keep going back until it works. CloneZilla again to an additional image. (keep the previous CloneZilla Image)

keep doing this until you have everything installed and working. If you break something really serious, you can easily restore to a previous version using the Clonezilla live CD.

You're on the bleeding edge Very few people will be able to help you with specific questions.

Tip: read all of the Ubuntu user manual.

2
  • 1
    Yes, I am very proficient under windows and have stayed away from linux over the college career because I always run into these issues. Not that I can't do my work, but that I can't do it for some seemingly small unrelated problem that only 5 people have ever faced. // I generally take the 1 million monkies typing approach to linux, eventually given enough monkies typing on keyboards the entirety of shakespere should be produced. Thus given enough fresh installs and misguided commands I should get (and do get) something eventually. I've wished for time to study it better since I first started. – KDecker Nov 24 '14 at 16:05
  • Cool! If the above is good enough to help you on your way, please accept the answer as valid. And thanks for the upvote already! – Fabby Nov 25 '14 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.