2

I'm norwegian so I have the norwegian keyboard as default, but now I need to write something in spanish, so I added the spanish keyboard layout. However, when I try to change between them the label in the toolbar changes, but I'm still typeing in norwegian. It only works if I remove the norwegian layout from the list, but if I then try to add it again I have to remove the spanish layout to get it to work. As I am switching between them all the time this becomes rather tedious. As far as I remember it worked fine before I installed Gnome3, but it's a long time ago. Is this a bug in Ubuntu or just Gnome? Thank you for your help.

closed as off-topic by karel, Zanna, Wild Man, David Foerster, Eric Carvalho Sep 18 '17 at 11:45

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – karel, Zanna, Wild Man, David Foerster, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • How are you changing between layouts? – Wilf Nov 23 '14 at 20:06
  • I've tried using the menu in the toolbar and by using the shortcut Super + Space. They both behave the same way. – Sindre Stephansen Nov 23 '14 at 21:09
  • I think it's a bug in Ubuntu introduced between 12.04 and 14.04. See the responses to this question. I have seen this discussed in a number of forums, but so far no solution. – Bobble Nov 26 '14 at 17:00
  • @Bobble Yes, that looks the same. I also tested it in Arch with Gnome, and a different installation of Ubuntu with just unity installed, and it worked fine for both. So is it a Ubuntu+Gnome problem, or did I just mess something up? – Sindre Stephansen Nov 26 '14 at 19:54
  • I don't think it is Gnome, because I looked at Debian Wheezy (Gnome 3.4.2) and Ibus seems to behave well there. From what I have read (sorry, can't find all the refs, but at least a couple were on Launchpad) other flavours of Ubuntu (Lubuntu in particular) are also affected. I am continuing to investigate, even jumping ship to BSD to find something that works for me. – Bobble Nov 28 '14 at 10:02
0

Seems like it just started to work, but I don't know why. The only thing I've done that might have fixed it was updating the system, but it might be something else entirely, so I can't give any advice to people in the same situation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.