0
cat /proc/asound/card0/codec* | grep Codec 

output:

   Codec: Realtek ALC272
   Codec: Intel CougarPoint HDMI

 laptop Model: Lenovo z570

  "HD-Audio-Models.txt" contains

  ALC662/663/272
  ==============
  asus-mode1    ASUS
  asus-mode2    ASUS
  asus-mode3    ASUS
  asus-mode4    ASUS
  asus-mode5    ASUS
  asus-mode6    ASUS
  asus-mode7    ASUS
  asus-mode8    ASUS 

I tried all nothing worked, also "options snd-hda-intel model=auto" didn't work.

1 Answer 1

0

this is the bug, this happens after a hard shutdown.

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1264213 

fixed it. now sound works properly. but wasted a lot of time doing nonsense for days.

added this line to the file "/etc/modprobe.d/alsa-base.conf"

      "options snd-hda-intel model=ideapad"  and then

       "sudo alsa force-reload"   and then

       reboot

for more info visit this thread => http://ubuntuforums.org/showthread.php?t=1316634 


edit: 

    the above solution is not a permanent solution.
    Installing NVidia driver fixed the problem. This looks ridiculous but works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .