I'm running Xubuntu 11.04 and i'm using a KeyOvation mac compatible Gold Touch keyboard. Because the weird ordering of ctrl, option, and the apple key, I wanted to remap the keys to my liking using xmodmap. Here's the settings file I'm using.

remove mod4 = Super_L
remove mod4 = Super_R
remove control = Control_L
remove control = Control_R
remove mod1 = Alt_L
remove mod1 = Alt_R
keysym Control_L = Super_L
keysym Control_R = Super_R
keysym Super_L = Alt_L
keysym Super_R = Alt_R
keysym Alt_L = Control_L
keysym Alt_R = Control_R
add control = Control_L
add control = Control_R
add mod4 = Super_L
add mod4 = Super_R
add mod1 = Alt_L
add mod1 = Alt_R

It works great when I call xmodmap on it. However, after a few minutes, the settings will no longer work and revert to the default settings and I have to call xmodmap again to get it to work. What could be the causes for this?

I've tried looking around a bit for this problem with little success. One guy claimed that he got around this by removing scim and I prefer not to do that.

Thanks in advance

  • does this AU Question help? askubuntu.com/questions/1142/… – fossfreedom Aug 1 '11 at 8:29
  • Not the same issue. The bindings just periodically reset regardless of what i'm doing – suyt Sep 4 '11 at 15:27
  • It may help if you go to the xfce Settings manager, Sessions and Startup and disable 'launch Gnome services on startup' at the 'Advanced' tab. – aquaherd Sep 22 '11 at 18:10

I had exactly the same problem (although using Xubuntu 12.04). What helped in my case was removing the keyboard-layout switch applet from my panel. Somehow this applet periodically sets the keyboard layout thus overriding anything that is set via xmodmap.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.