64

I am using ubuntu-11.04.

I followed these steps on this site:

So far my apache2, php, and mysql are working fine except phpmyadmin... Whenever I run this:

http://localhost/phpmyadmin/

I get this error on my browser:

Not Found

The requested URL /phpmyadmin/ was not found on this server.


Apache/2.2.17 (Ubuntu) Server at localhost Port 80

  • Have you restarted the apache server: /etc/init.d/apache2 restart – Tom Aug 2 '11 at 8:52
  • Consider, checking answer provide by @sangharsh. – Ketan Sep 8 '18 at 7:04

10 Answers 10

146

Please read this section in Ubuntu wiki. You will need to configure your apache2.conf to make phpMyAdmin works.

gksu gedit /etc/apache2/apache2.conf

Then add the following line to the end of the file.

Include /etc/phpmyadmin/apache.conf

Then restart apache

/etc/init.d/apache2 restart
| improve this answer | |
  • 9
    I love you @JohanSJA – Programming Noob Jul 23 '12 at 8:59
  • 1
    No need of manual configurations, apt-get ing is enough to run phpmyadmin – Tachyons Feb 13 '13 at 14:11
  • I finally got JohanSJA's instructions to work after I restarted the apache server using /etc/init.d/apache2 restart. Also I moved the Include line to the bottom of the file as instructed. – boulder_ruby Jun 16 '13 at 16:34
  • 1
    I included apache.conf at the bottom and restarted apache server afterwards, still getting not found, how can I debug it ? – Sohail Oct 12 '13 at 13:59
  • This worked for me, just remember to restart apache2 – williamcarswell Jun 18 '14 at 8:39
24

Tried various different ways.

Finally this, this from ubuntu documentation, worked for me:

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo a2enconf phpmyadmin
sudo service apache2 reload
| improve this answer | |
  • 1
    Worked on 15.10. – Rael Gugelmin Cunha Nov 22 '15 at 11:58
  • also worked on 16.04 – Rahul Sharma Apr 13 '17 at 5:58
  • 1
    This should be marked as the correct recommended way to achieve this – Jimmy Obonyo Abor Apr 15 '17 at 21:25
  • This is the correct way. – Ketan Sep 8 '18 at 7:03
  • thanks. finally something that works. this should be the best answer. – Don Dilanga Jan 22 '19 at 7:47
6

Ubuntu 16.04

After installing and setting up user and password in mysql and phpmyadmin execute following command

sudo apt install php-gettext

Worked for me...

Edit1 If you just need apache, phPmyAdmin, and MySql just to a Web Application Environment then I Suggest for exampp wich Install All three for you and then you are Ready to go Here is Link

XAMPP Installers and Downloads | Apache Friends

| improve this answer | |
  • This worked for me too. php-gettext was missing. I wonder, why none of the documentation mention about this module... – JTheDev Jan 25 '17 at 6:43
3

Don't panic ! Just run the following code with root permission in terminal

sudo ln -s /usr/share/phpmyadmin /var/www
| improve this answer | |
2

I faced same problem, I fixed it by running sudo dpkg-reconfigure phpmyadmin

give new username and password

| improve this answer | |
2

You need to find where phpmyadmin is located, e.g. locate phpmyadmin, some it will return the location, such as /usr/share/phpmyadmin.

Then you can symlink it like this: sudo ln -s /usr/share/phpmyadmin /var/www

Starting Ubuntu 14.04 and up, /var/www is no longer work instead /var/www/html. e.g, sudo ln -s /usr/share/phpmyadmin /var/www/html

Reference: Where to place my local website starting with the 2.4.7 version of apache2?

| improve this answer | |
  • If you are planning to host wordpress or another website in apache root i.e. /var/www/html then use sudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadmin. That way you can access phpmyadmin using http://yourdomain/phpmyadmin – nandan Feb 27 '19 at 12:41
0
sudo sed -i '$ a\Include /etc/phpmyadmin/apache.conf' /etc/apache2/apache2.conf && sudo service apache2 restart && sudo apt-get install php-gettext`

Tested and works. Running that should solve it for anyone who wants a 1 liner.

| improve this answer | |
0

I tried all the above methods and they didn't work for me. Finally this one worked.

Open terminal and switch to super user using the command: sudo su

After installing phpmyadmin using instructions given in the link, open /etc/apache2/conf-available.

You will find a file there named phpmyadmin.conf. Copy it to /etc/apache2/conf-enabled. Or simply use the command

sudo cp /etc/apache2/conf-available /etc/apache2/conf-enabled

Restart apache2 (sudo service apache2 restart) and then open the link localhost/phpmyadmin in a browser.

| improve this answer | |
0

finally this work for ubuntu 14.04 LTS

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadmin
sudo service apache2 restart

now type localhost/phpmyadmin in web browser.

| improve this answer | |
-3

I was facing the same problem.

Firstly check if the directory called /usr/share/phpmyadmin/ exists. If it does, just move it to /var/www/phpmyadmin by executing this command:

mv /usr/share/phpmyadmin /var/www/phpmyadmin

Open your browser and open http://localhost/phpmyadmin. Now it should work.

| improve this answer | |
  • 6
    This will break the uninstaller, and will cause installation/upgrade issues. You will need to symlink the directory. sudo ln -s /usr/share/phpmyadmin /var/www/phpmyadmin should correctly symlink. – Thomas Ward Jul 26 '12 at 15:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.