0

Trying to change my Input Method with im-config outputs this after I select and save what I want to use.

head: error reading ‘adt-bundle-linux-x86_64-20140702’: Is a directory
tail: error reading ‘adt-bundle-linux-x86_64-20140702’: Is a directory
E: Configuration in adt-bundle-linux-x86_64-20140702 is manually managed. Doing nothing.

Why is im-config trying to read a directory that's in my home folder? Because this is preventing me from being able to change my input method from default to ibus

How can I tell im-config to change my input method without it trying to read a directory in my home folder? It shouldn't be doing that, it's suppose to change my im-config I've selected.

to produce this error all I'm doing is;

 sudo im-config
[sudo] password for user:

** (zenity:20841): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist

** (zenity:20841): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist

(zenity:20841): IBUS-WARNING **: The owner of /home/user/.config/ibus/bus is not root!

** (zenity:20852): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist

** (zenity:20852): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist
head: error reading ‘adt-bundle-linux-x86_64-20140702’: Is a directory
tail: error reading ‘adt-bundle-linux-x86_64-20140702’: Is a directory
E: Configuration in adt-bundle-linux-x86_64-20140702 is manually managed. Doing nothing.

I need to be able to change my input method so that iBus will work correctly with other language inputs like iBus-Anthy as well as some applications that require an input method it can actually read, because it doesn't work on default as it's currently selected on.

I've also checked that running im-config as normal user level still gets the same error as when trying to run as root.

  • What Ubuntu version are you using? – Gunnar Hjalmarsson Nov 22 '14 at 14:55
  • I'm using 14.10 – user94959 Nov 22 '14 at 16:23
0

im-config is not supposed to be run as root.

Try to run this command:

sudo rm ~/.xinputrc

and then run im-config without sudo again.

  • well that was kinda obvious… but anyway -->> rm: cannot remove ‘/home/user/.xinputrc’: No such file or directory and same thing again with the said error like I mentioned before. – user94959 Nov 22 '14 at 16:21
  • @user94959: I can't see anything obvious with your issue. ;) im-config is supposed to apply head() and tail() to a file represented by the $IM_CONFIG_XINPUTRC variable, whose value should be either "/etc/X11/xinit/xinputrc" or "$HOME/.xinputrc". From the output you showed us it looks like $IM_CONFIG_XINPUTRC is assigned the value "adt-bundle-linux-x86_64-20140702", which is a complete mystery to me. What happens if you open the Language Support GUI and set the desired input method from there? (Actually that's the easiest way. Normally you shouldn't need to call im-config directly.) – Gunnar Hjalmarsson Nov 23 '14 at 0:02
  • The issue here is it's trying to write to a directory which shouldn't be doing that when it's suppose to create and write to the config file .xinputrc in the home directory instead it's looking at a directory to write to. I eventually found my solution, from Terminal I went to see what happened when I did im-config -c instead of the GUI interface with Zenity and I was able to set the desired input method without the said errors with it trying to write to a directory, and it properly created and written .xinputrc file like it's suppose to. – user94959 Nov 23 '14 at 2:16
  • @user94959: Ok, great that you solved it. Really strange that the use of zenity can cause such confusion, though. (Btw, it means that using Language Support, as I suggested, most likely had worked fine too.) – Gunnar Hjalmarsson Nov 23 '14 at 2:34
0

I eventually found my solution I eventually came to, before that typing im-config without any options into gnome-terminal would produce these errors errors;

head: error reading ‘adt-bundle-linux-x86_64-20140702’: Is a directory
tail: error reading ‘adt-bundle-linux-x86_64-20140702’: Is a directory
E: Configuration in adt-bundle-linux-x86_64-20140702 is manually managed. Doing nothing.

in the home directory if there's no .xinputrc file it then looks at trying to write to a directory after you've made your selections with zenity GUI interface instead of creating a new file and writing to .xinputrc

Solution:

In terminal instead of just typing im-config alone do;

$ im-config -c

and you will instead be configuring through terminal screen to complete the setup properly and will properly create and write .xinputrc file into your home directory without doing the error of trying to write to a directory.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy