0

I installed Ubuntu 14.10 on a Lenovo Thinkpad, which is a All-In_One Desktop without any batteries.

System is working fine, up to 2 problems:

  1. Shortly after logon, the desktop is shown and even a terminal autostarted. Then, suddenly, the display resolution is again reset (i.e. screen goes dark), and when it comes back I see the message "Battery critically low". This is merely an annoyance, from that point on, the system continues to work. But it makes me wary that the system doesn't know exactly my computer.

  2. Probably related, I have always 4 kidle_inject processes slowing down each logical CPU by 20 to 50%, even if the system is more than 80% idle according to top. I already tried to disable intel_pstate, but it has no effect. What an idiotic situation! Dear LINUX/Ubuntu devs, don't you think that when I want to save power, I buy a smaller CPU. Now, the situation is such, when I do a full rebuild of my project (I do Java development) on the machine, it simply takes twice as long, just for sake of "power saving". And working in eclipse is barely impossible, unless I quit chrome and any other applications. So please, tell me:

How can I disable any and all stuff that redcues my CPU performance? Specifically kidle_inject?

EDIT: found out that there is a device driver named intel_powerclamp that injects the idle time, and how to disable it.

What could be the reason my desktop is treated as a battery-powered device, and how to suppress it?

  • It looks like Ubuntu thinks I must have batteries because Lenovo choose to equip this "Thinkpad" with a mobile processor. Yeah, this pad has given me reason to think that I never again by such a thing. Mission accomplished. – Ingo Dec 6 '14 at 18:27
1

Found a way to disable the crapware called "intel_powerclamp":

sudo su
cd /etc/modprobe.d
cat >intel_powerclamp.conf
# avoid shitty powerclamp
install intel_powerclamp /bin/true
^D

and then, after a reboot, no kidle_inject processes force you to save power.

  • You should probably make a backup of the intel_powerclamp.conf file just in case you need to restore it :).. (Im not quite sure what the install line does, so if you need special instructions to undo that, you might wanna include that :D) – Moose Nov 22 '14 at 15:37
  • @ThatCoderGuy The file didn't exist previously, so nothing to save. The install line just fakes a successful loading of the module through /bin/true – Ingo Nov 22 '14 at 15:53
  • Ahh okay :).. My bad :P i thought you were overwriting a kernel module :') – Moose Nov 22 '14 at 15:54
  • I'd advocate that intel_powerclamp isn't nearly a crapware - it is a great development; it just lacks some adequate and transparent user controls. Oftentimes I get really sick because of developer ignorance with respect to power saving: my laptop is burning because of some stupid web application (really just a buggy javascript event loop), my electricity bill is burning too (because Unity thinks that it's fine to consume another CPU core). Much more developers should care about power than is the case nowadays. – ulidtko Dec 8 '14 at 12:09
  • @ulidtko As I said, when I fear high electricity bills, I can buy a less powerful computer. In addition, by physical laws, you can't save energy by making the processor wait (unless energy efficiency is much lower on full speed, which I doubt) you can at most save energy use per time unit. But if you have a computation that takes normally 10 minutes, it doesn't help to make it run 30 minutes, whereof 28 minutes, the mechanical CPU ventilation is working at highest expense. – Ingo Dec 8 '14 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.