On 14.10 holding shift at boot time doesn't bring up the grub menu. Is there another way I can boot in single user mode?

I have bricked my sudoers file so I can't use sudo btw.

I don't get a grub menu as I only have one OS on my machine.

I have tried changing every combination of boot types in the BIOS.

  • You will need to add more details to your question. Why you should need to hold shift key? The grub menu should appear on its own at boot. – Horizon Nov 22 '14 at 9:46
  • do you dual boot? – thomas-peter Nov 22 '14 at 9:47
  • Yes, I do. If you have only Ubuntu installed and trying to get the grub menu, probably there is some other key than SHIFT. – Horizon Nov 22 '14 at 9:52
  • I a pinch, use a installation/rescue disk to boot. You can easily adapt askubuntu.com/a/145253/16395 – Rmano Nov 22 '14 at 11:45

In the end I tried tapping both shift keys really fast on a system boot. This would only bring up the menu about one time in five. I think it's because the mohterboard is so new and so very fast at getting to the bootloader stage.

Then I chose to go into rescue mode and then from the menu when to a root prompt.

After getting a root prompt I did the usual..

 # mount -o remount,rw

Once the file system is in rw mode I then edited to the sudoers file.

Leasons learned

  • Always use visudo to edit your sudoers file so that syntax is checked for you before saving.
 # sudo visudo
  • Annoying, ubuntu uses nano as it's default text editor, which put me off using visudo. So another good tip is to change your default editor by using update-alternatives
# sudo update-alternatives --config editor
  • It's probably a good idea to set a password (a very secure one obviously) for root.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.