1

I am using Ubuntu 14.04 and have installed windows 7 using virtual box. After Ubuntu update, when I try to power on windows 7, the following error message comes:

Failed to open a session for the virtual machine Windows 7 x64.

The virtual machine 'Windows 7 x64' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

I have tried the following and its still not working

sudo apt-get install linux-headers-generic build-essential dkms
sudo apt-get remove --purge virtualbox-dkms
sudo apt-get install virtualbox-dkms

It shows a dependency error when installing virtualbox-dkms

The following packages have unmet dependencies:
 virtualbox-dkms : Depends: virtualbox (>= 4.3.10-dfsg-1)
E: Unable to correct problems, you have held broken packages.
4

Had the same issue after ubuntu 14.04 update, this is what worked for me:

sudo apt-get install dkms

sudo /etc/init.d/vboxdrv setup
2

Had the same problem as you with a recent Ubuntu update. Updating VirtualBox to 4.3.20 worked for me. Download the deb file for Ubuntu 14.04 here:

https://www.virtualbox.org/wiki/Linux_Downloads

Then uninstall VirtualBox 4.3.18 and install new version:

sudo apt-get remove virtualbox

sudo dpkg -i virtualbox-4.3_4.3.20-96996~Ubuntu~raring_amd64.deb

Replace amd64 with i386 if you're running a 32 bit system. Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.