12

When running the emulator, Android Studio reports the following message:

Please ensure KVM is properly installed and usable.

CPU acceleration status: KVM is not installed on this machine (/dev/kvm is missing)

However, KVM is installed as shown by the following:

which kvm

/usr/bin/kvm

Thanks...

14

See the instructions here: https://help.ubuntu.com/community/KVM/Installation

In short:

sudo apt-get install qemu-kvm libvirt-bin ubuntu-vm-builder bridge-utils
sudo adduser `id -un` libvirtd
sudo adduser `id -un` kvm

Then log out and back in again, and check that it is working by running:

virsh -c qemu:///system list

Some more instructions from Intel: https://software.intel.com/en-us/blogs/2012/03/12/how-to-start-intel-hardware-assisted-virtualization-hypervisor-on-linux-to-speed-up-intel-android-x86-emulator

| improve this answer | |
  • 1
    Got it, I've not enabled VT on BIOS. – fikr4n Dec 2 '14 at 7:49
  • Seems like a good direction – Csaba Toth Jan 2 '15 at 21:47
  • Should be marked as an answer I think – Csaba Toth Jan 3 '15 at 20:16
  • I did all that, and I still have the poster's problem. – DanielLC Jan 14 '15 at 1:38
4

I had exactly the same problem. I managed to fix it after minimal fuss by enabling virtual technology in the BIOS settings. It may be a slightly different method for different computers but on my HP Pavillion Laptop you simply press F10 at start up to get the BIOS options. Then find the tab which allows you to set VT to enabled. As soon as this is done (assuming you have kvm), it works. Just restart and run in terminal.

kvm-ok
| improve this answer | |
1

I had the same problem and it was because of the modprobe:

whk @ whk-MS-7817: ~ $ sudo kvm-ok
[sudo] password for whk:
INFO: / dev / kvm does not exist
HINT: sudo modprobe kvm_intel
modprobe: ERROR: ../libkmod/libkmod.c:556 kmod_search_moddep () moddep could not open file '/lib/modules/3.13.0-43-generic/modules.dep.bin'

I found the same error message here:https://dainaccio.wordpress.com/2014/12/19/how-to-solve-wifi-not-working-in-a-fresh-installed-linux-mint-17-sony-vaio-atheros-ath9k/

I checked the version of my kernel:

whk @ whk-MS-7817: ~ $ uname -mrs
3.13.0-43-generic Linux x86_64

It was the same version of the post so talves was a bug, so I proceeded to repair:

sudo apt-get install --reinstall linux-image-3.13.0-43

And presto!

whk @ whk-MS-7817: ~ $ sudo kvm-ok
INFO: / dev / kvm does not exist
HINT: sudo modprobe kvm_intel
INFO: Your CPU Supports KVM extensions
KVM acceleration can be used

Now reboot and working properly. Tested in Android Studio 1.0.2 and Ubuntu 14.04 LTS

| improve this answer | |
1

After installing KVM like Ralf demonstrated in his answer above, you've got to enable Virtual Technology (VT) on Bios.

Press F10 on boot to access your BIOS setting on your machine. (This might be different depending on your machine)

Example using HP EliteBook 8440p

| improve this answer | |
-1

I had same problem and in the end it was a BIOS issue. The problem is that you have disabled the virtualization option.

To solve it, you have to enter BIOS setup and activate this option.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.