5

This question already has an answer here:

I have a small issue with my Ubuntu (I think After an upgarde). When I try to login (Login Screen), I get disconnected and get back to the screen (again & again).

I tried:

  • Trying to login with others Desktop environements.
  • Booting from old kernel.
  • log in via command line [apt-get update && apt-get upgrade].
  • removing ~/.gconf directory.
  • sudo apt-get install --reinstall ubuntu-desktop and sudo apt-get install unity

None of these solutions worked.

marked as duplicate by Charles Green, Sylvain Pineau, muru, bcbc, Eric Carvalho Nov 21 '14 at 23:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

10

Press Ctrl+Alt+F3 and login into the shell using your username and your password. In this case username will be your username you set when you installed Ubuntu.

Now run ls -lah. If in the output the line(and look for the line that ends with .Xauthority)

-rw-------  1 root root   53 Nov 29 10:19 .Xauthority

then you need to do chown username:username .Xauthority and try logging in.

Else, do ls -ld /tmp. Check for the first 10 letters in the left: they should read exactly so: drwxrwxrwt.

drwxrwxrwt 15 root root 4096 Nov 30 04:17 /tmp

Else, you need to do sudo chmod a+wt /tmp and check again.

If not both, I'd recommend you either
Make sure you are connected to internet with DHCP on.

  1. sudo apt-get purge lightdm
  2. sudo apt-get update
  3. sudo apt-get install lightdm
  4. dpkg-reconfigure lightdm

Now type sudo shutdown -r now to restart.

  • thank you sir, problem solved after reinstalling lightdm – Jesus Nov 21 '14 at 20:28
  • Used this method to get an install on an old eeePC working. Thank you. – twip Dec 27 '16 at 17:28
  • thank you! This answer solved my problem twice. Once it was .Xauthority this time it was lightdm – StackUP Apr 28 '18 at 17:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.