… due some login problems. I just remove and reinstalled unity-greeter successfully, but now I cannot login in graphic mode with the default user I already had. Does anyone knows why is this happening or what can I do to fix this? A workaround in the web I found that changing the autologin-user=mylocaluser in 50-unity-greeter.conf it would solve this issue but nothing worked.

In terminal mode (Ctrl+Alt+F1) I can change users passwords but still I cannot login in graphic mode.

  • When you log in to the terminal using (Ctrl-Alt-F1). You can start the GUI by running the command startx I just tried this on my VM but the problem is whether or not the HUD actually shows up... It seems that it doesn't for some reason. I know in other OSs like Raspbian if you use startx then It'll have its full DE pop up. Nov 20 '14 at 17:18
  • startx works but just gave me the ubuntu wallpaper only, no sidebar, no options at right upper corner...clicking the right mouse button I could "change" things but closing the all settings window the ubuntu wallpaper was the only thing I can have...any suggestions??? Nov 20 '14 at 18:08
  • For more info about this, please log in on a virtual terminal (Ctrl+Alt+F1), then switch back to grapical mode (Ctrl+Alt+F7 or F8) and try to log in. Switch back to virtual terminal and post the last lines of /var/log/auth.log that are related to your GUI log in attempt. Feb 22 '15 at 23:39

Try deleting the .Xauthority file from your home directory and reboot. rm .Xauthority

  • Tobias, I did what you've said but nothing, I'm still inthe login screen...just said "Failed to start session" it didn't accepted the password I changed in Ctrl-Alt-F1 mode...any suggestions are welcome Nov 20 '14 at 18:12
  • It's definitely a . file or folder in your home directory, but which one I can't say for sure. You could temporarily moving all of them to a different folder.
    – Tobias
    Nov 20 '14 at 18:17
  • if I move them all anywhere, what would the next step?? reboot?? all the files and folders belongs to the user I have...root and guest users not active Nov 20 '14 at 19:04
  • You can just move to another folder within your home directy, but yeah, reboot and try and login.
    – Tobias
    Nov 20 '14 at 19:11
  • I moved them all including the hidden ones, but still can't login, do you think If I enable the root user would help??? Nov 20 '14 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.