0

I have been trying to install a few prog and it doesn't seem to work. For example with skype, I use the

sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.de

and it all seems to work fine apart from at the end where it says

dpkg: error processing package skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Errors were encountered while processing:
 skype

The whole code is here:

sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb
(Reading database ... 165439 files and directories currently installed.)
Preparing to unpack skype-ubuntu-precise_4.3.0.37-1_i386.deb ...
Unpacking skype (4.3.0.37-1) over (4.3.0.37-1) ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libc6 (>= 2.3.6-6~).
 skype depends on libc6 (>= 2.7).
 skype depends on libgcc1 (>= 1:4.1.1).
 skype depends on libqt4-dbus (>= 4:4.5.3).
 skype depends on libqt4-network (>= 4:4.8.0).
 skype depends on libqt4-xml (>= 4:4.5.3).
 skype depends on libqtcore4 (>= 4:4.7.0~beta1).
 skype depends on libqtgui4 (>= 4:4.8.0).
 skype depends on libqtwebkit4 (>= 2.2~2011week36).
 skype depends on libstdc++6 (>= 4.2.1).
 skype depends on libx11-6.
 skype depends on libxext6.
 skype depends on libxss1.
 skype depends on libxv1.
 skype depends on libssl1.0.0.
 skype depends on libpulse0.
 skype depends on libasound2-plugins.

dpkg: error processing package skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Errors were encountered while processing:
 skype

This does it with other prog like Ubuntu Tweak as well.

Thanks a lot for any help

0

You're installing a .deb file that has dependencies. See this section from your output:

 skype depends on libc6 (>= 2.3.6-6~).
 skype depends on libc6 (>= 2.7).
 skype depends on libgcc1 (>= 1:4.1.1).
 skype depends on libqt4-dbus (>= 4:4.5.3).
 skype depends on libqt4-network (>= 4:4.8.0).
 skype depends on libqt4-xml (>= 4:4.5.3).
 skype depends on libqtcore4 (>= 4:4.7.0~beta1).
 skype depends on libqtgui4 (>= 4:4.8.0).
 skype depends on libqtwebkit4 (>= 2.2~2011week36).
 skype depends on libstdc++6 (>= 4.2.1).
 skype depends on libx11-6.
 skype depends on libxext6.
 skype depends on libxss1.
 skype depends on libxv1.
 skype depends on libssl1.0.0.
 skype depends on libpulse0.
 skype depends on libasound2-plugins.

In this output you can see some of your installed packages that are old, like libc6 asking for a new version >= 2.3.6-6~, and some missing packages: the ones without specified version, which means they're not installed - like libx11-6.

Usually install the list of missing packages using apt-get (like sudo apt-get install libxx11-6) would solve the problem. But a package asking you to upgrade the libc is not usual: libc is one of the main libraries of Unix systems.

Or you never update your system, or you're running a different version of Ubuntu.

Had you updated your system with sudo apt-get update && sudo apt-get upgrade?

Are you using other Ubuntu version then precise? (As your skype deb installer is tagged with precise).

2
  • Hi Rael,I am using the latest version of Ubuntu. It just had to actually update the apt-get update did the trip. – user350501 Nov 21 '14 at 12:34
  • @user350501 So, Mark an answer as correct, please. – Rael Gugelmin Cunha Nov 21 '14 at 14:04
0

If you install a local .deb file, dpkg does not automatically resolve the dependencies. To resolve those automatically, you could use gdebi to install local .deb packages. Install it with

sudo apt-get install gdebi

if it is installed, go to the folder where you have the .deb file and type

sudo gdebi skype-ubuntu-precise_4.3.0.37-1_i386.deb

dependencies shoud now be resolved and skype installed.

1
  • this worked once I ran the update. thanks a lot Bram – user350501 Nov 21 '14 at 12:35
0

I had exactly the same problem. It was fixed by enabling Canonical partners software site and after that I was able to finish Skype installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.