0

I work on UBUNTU. And I have windows on my virtualbox. Yesterday when I updated my Ubuntu I am not able to start my virtualbox. It is giving me following error message.Please if anyone can help me.

The vboxdrv kernel module is not loaded. Either there is no module
available for the current kernel (3.2.0-72-generic) or it failed to
load. Please recompile the kernel module and install it by
sudo /etc/init.d/vboxdrv setup
You will not be able to start VMs until this problem is fixed.

After that I run the following command:

archana@archana-Vostro-1450:~$ sudo apt-get install dkms
[sudo] password for archana: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
libpam-winbind ttf-umefont wine1.4-amd64 gcompris-data wine1.4 ttf-dustin
language-pack-kde-zh-hans-base libcapi20-3 firefox-locale-zh-hans unixodbc
wine1.4-common wine-gecko1.4 wine-gecko1.4:i386 winetricks libgif4:i386
language-pack-kde-en wine kde-l10n-engb wine1.4-i386:i386 fonts-dustin
language-pack-zh-hans-base ttf-unfonts-core libmpg123-0 kde-l10n-zhcn
language-pack-zh-hans language-pack-kde-zh-hans winbind libodbc1 fonts-droid
language-pack-kde-en-base python-pysqlite2 gcompris-sound-en ttf-droid
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
fakeroot
The following NEW packages will be installed:
dkms fakeroot
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 160 kB of archives.
After this operation, 669 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
dkms fakeroot
Install these packages without verification [y/N]? y
Get:1 http://repo.iitd.ernet.in/ubuntu/ precise-updates/main dkms all 2.2.0.3-1ubuntu3.2 [72.6 kB]
Get:2 http://repo.iitd.ernet.in/ubuntu/ precise/main fakeroot amd64 1.18.2-1 [87.2 kB]
Fetched 160 kB in 1s (115 kB/s)  
Selecting previously unselected package dkms.
(Reading database ... 322489 files and directories currently installed.)
Unpacking dkms (from .../dkms_2.2.0.3-1ubuntu3.2_all.deb) ...
Selecting previously unselected package fakeroot.
Unpacking fakeroot (from .../fakeroot_1.18.2-1_amd64.deb) ...
Processing triggers for man-db ...
Setting up dkms (2.2.0.3-1ubuntu3.2) ...
Setting up fakeroot (1.18.2-1) ...
update-alternatives: using /usr/bin/fakeroot-sysv to provide /usr/bin/fakeroot (fakeroot) in auto mode.
archana@archana-Vostro-1450:~$ sudo virtualbox
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
available for the current kernel (3.2.0-72-generic) or it failed to
load. Please recompile the kernel module and install it by
sudo /etc/init.d/vboxdrv setup
You will not be able to start VMs until this problem is fixed.
^Carchana@archana-Vostro-1450:~$ ^C
archana@archana-Vostro-1450:~$ run sudo /etc/init.d/vboxdrv setup
No command 'run' found, did you mean:
 Command 'zrun' from package 'moreutils' (universe)
 Command 'runq' from package 'exim4-daemon-heavy' (main)
 Command 'runq' from package 'sendmail-bin' (universe)
 Command 'runq' from package 'exim4-daemon-light' (main)
 Command 'grun' from package 'grun' (universe)
 Command 'qrun' from package 'torque-client' (universe)
 Command 'qrun' from package 'torque-client-x11' (universe)
 Command 'lrun' from package 'lustre-utils' (universe)
 Command 'rn' from package 'trn' (multiverse)
 Command 'rn' from package 'trn4' (multiverse)
 Command 'rup' from package 'rstat-client' (universe)
 Command 'srun' from package 'slurm-llnl' (universe)
run: command not found
archana@archana-Vostro-1450:~$ 
  • how did you install virtalbox ? Did you run sudo /etc/init.d/vboxdrv setup ? If that command works, you have to update the vbox kernel module with each kernel update. It is usually easier to install the vbox package in the ubuntu repositories. – Panther Nov 20 '14 at 5:10
  • Ye I have tried it and got the result:archana@archana-Vostro-1450:~$ sudo /etc/init.d/vboxdrv [sudo] password for archana: Usage: /etc/init.d/vboxdrv {start|stop|stop_vms|restart|force-reload|status|setup} what should I do next? archana@archana-Vostro-1450:~$ – Archana Roy Nov 20 '14 at 6:51
  • 1
    You forgot the "setup" at the end and thus are getting a usage error. sudo /etc/init.d/vboxdrv setup . The alternate, once again, is to intstall virtualbox from the repositories. Better, use KVM. Virtmanager is a ggraphical front end for KVM and KVM is open source and part of the kernel (so no 3rd party apps). – Panther Nov 20 '14 at 14:09
0

Have you tried reinstalling Virtualbox and importing the Virtualmachine by running the .vdi (or whatever Disk image format you are using)?

| improve this answer | |
  • No i have not tried this. I am afraid if reinstalling would affect windows and files stored on it. I have lots of data stored there. – Archana Roy Nov 20 '14 at 6:53
  • A backup is the first thing you should do. then try to get the virtualbox deinstalled without deleting the image of your windows. create a new windows machine with the existing windows image and try to start it. – zulu34sx Nov 27 '14 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.