0

Recently I updated some packages in my Dell vostro 2520 laptop and after that my broadcom network driver is not working. When listing details of this network card with sudo lshw -C Network it shows UNCLAIMED. No wired and wifi connections work.

Here is the output of lspci:

07:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 07)

I was able to connect to ethernet after typing modprobe 8169. Below are the results from the other commands.

siva@siva-Vostro-2520:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr e0:db:55:c7:ff:3f  
      inet addr:10.10.10.109  Bcast:10.10.10.255  Mask:255.255.255.0
      inet6 addr: fe80::e2db:55ff:fec7:ff3f/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:84 errors:0 dropped:0 overruns:0 frame:0
      TX packets:79 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:8514 (8.5 KB)  TX bytes:15491 (15.4 KB)
      Interrupt:44 Base address:0xc000 

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:34 errors:0 dropped:0 overruns:0 frame:0
      TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:2690 (2.6 KB)  TX bytes:2690 (2.6 KB)

siva@siva-Vostro-2520:~$ sudo ethtool -s eth0 speed 100 autoneg off
siva@siva-Vostro-2520:~$ dmesg | grep -e eth0 -e r816
[   82.540591] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[   82.540628] r8169 0000:09:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   82.540703] r8169 0000:09:00.0: setting latency timer to 64
[   82.540798] r8169 0000:09:00.0: irq 44 for MSI/MSI-X
[   82.541504] r8169 0000:09:00.0: eth0: RTL8168evl/8111evl at 0xffffc9000031c000, e0:db:55:c7:ff:3f, XID 0c900800 IRQ 44
[   82.541509] r8169 0000:09:00.0: eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[   82.542017] r8169 0000:09:00.0: PME# enabled
[   82.609758] r8169 0000:09:00.0: PME# disabled
[   82.734342] r8169 0000:09:00.0: eth0: link down
[   82.734349] r8169 0000:09:00.0: eth0: link down
[   82.734519] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   82.734739] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   85.141266] r8169 0000:09:00.0: eth0: link up
[   85.141556] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   95.905762] eth0: no IPv6 routers present
[  159.852995] r8169 0000:09:00.0: eth0: link down
[  162.886021] r8169 0000:09:00.0: eth0: link up
  • Please edit your question to add details of your devices from the terminal: lspci -nn | grep -e 0200 -e 0280 Thanks. – chili555 Nov 19 '14 at 21:19
  • Pl. help me out. it looks like an issue for many, I tried different links, but could not find the right solution – siva raj Nov 19 '14 at 22:28
  • Chili555- ethernet works after the modprobe r8169. let me know what next. Thanks a lot for showing me the way – siva raj Nov 20 '14 at 18:14
  • hello Chili555, Mine is a 64 bit, Intel. So should I download the 32-bit/i386 driver? – siva raj Nov 22 '14 at 10:05
  • What did the command arch tell you? If it reports i686, you need the 32-bit version, which is tricky and may not work. If it reports x86_64, then you need the 64-bit version. – chili555 Nov 22 '14 at 14:14
1

Let's try to coax your ethernet to life first so we can use it to fix the wireless. Please hook up the ethernet with a known good cable, open a terminal and do:

sudo modprobe r8169
ifconfig

Do you have an ethernet interface, probably eth0? If so, then do:

sudo ethtool -s eth0 speed 100 autoneg off

Now does it connect? If so, we'll amend one file and make it persistent. If not, see if the logs have any clues:

dmesg | grep -e eth0 -e r816

Glad the ethernet is working! As for the wireless, in Ubuntu 12.04, it is probably impossible to get working unless you have installed a 64-bit system; check:

arch

If so, please check here: How do I install BCM43142 wireless drivers for Dell Vostro 3460/3560? Otherwise, I suggest you install Ubuntu 14.04 LTS or 14.10 in which case, all you need do is:

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

And then reboot.

If the ethernet driver refuses to load on boot, please do:

sudo -i
echo r8169  >>  /etc/modules
depmod -a
exit

You should be all set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.