I'm using Ubuntu 14.04 LTS. Basically, I can load like three webpages and then the signal drops. It still shows I'm connected with 4/5 bars or whatever you'd like to call them, but none of my traffic gets through. Later the night I was testing it, my router crashed. Thoughts?


2 Answers 2


The driver rtl8192cu is notoriously unstable. There is a fix. Please disconnect your wireless connection (unplug the USB adapter that contains the Realtek chipset), and temporarily connect to the internet by means of an ethernet cable or by means of another wireless chipset that does function well.

Now install some applications for building the right driver via a terminal:

sudo apt-get install linux-headers-generic build-essential dkms git

Now download the source code of the driver via a terminal:

git clone https://github.com/pvaret/rtl8192cu-fixes.git

Set it up as a DKMS module via a terminal:

sudo dkms add ./rtl8192cu-fixes

Build and install the new driver via a terminal:

sudo dkms install 8192cu/1.10

Refresh the module list via a terminal:

sudo depmod -a

Blacklist the faulty driver via a terminal:

sudo -i
echo "blacklist rtl8192cu"  >>  /etc/modprobe.d/blacklist.conf

Detach the ethernet and reboot; the wireless should be working much better now.

  • The internet adapter isn't detected at all anymore. I copy/pasted all the commands, in order, into the terminal. However, I did it while the adapter was inside but disabled. How bad did I mess up? Do I NEED to detatch ethernet to see the wifi adapter detected? Nov 20, 2014 at 4:12
  • NVM, redid with it unplugged and all is well. Thanks. Nov 20, 2014 at 14:46
  • May God bless you! Aug 9, 2015 at 3:14
  • This worked fine in 15.10 today, I just had to change to : sudo dkms install 8192cu/1.10 Feb 2, 2016 at 5:57
  • Works on ubuntu 16.04. Thank you!
    – Nearoo
    Jul 3, 2016 at 17:12

Here's what worked for me:

sudo apt-get install git build-essential linux-headers-generic dkms
git clone https://github.com/dz0ny/rt8192cu.git --depth 1
cd rt8192cu
sudo make install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.